jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Gaul (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (JCLOUDS-645) Incorrect endpoint url chosen for default region of HPCloud Object Storage
Date Mon, 26 Oct 2015 03:53:27 GMT

     [ https://issues.apache.org/jira/browse/JCLOUDS-645?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Gaul updated JCLOUDS-645:
--------------------------------
    Labels: swift  (was: )

> Incorrect endpoint url chosen for default region of HPCloud Object Storage
> --------------------------------------------------------------------------
>
>                 Key: JCLOUDS-645
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-645
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-blobstore
>    Affects Versions: 1.8.0
>            Reporter: Shri Javadekar
>            Assignee: Chris Custine
>              Labels: swift
>             Fix For: 2.0.0
>
>
> JClouds seems to be choosing the wrong endpoint from the service catalog returned by
HPCloud Object Storage.
> From what I see there are two endpoints returned in the Object Storage part of the service
catalog.
> D 07-31 13:21:22.122 pool-1-thread-1 jclouds.wire:59 |::] << "          "publicURL":
"https:\/\/region-a.geo-1.objects.hpcloudsvc.com\/v1\/53176293441764",[\n]"
> D 07-31 13:21:22.124 pool-1-thread-1 jclouds.wire:59 |::] << "          "publicURL":
"https:\/\/region-b.geo-1.objects.hpcloudsvc.com\/v1\/53176293441764",[\n]"
> I do not have any region configured.
> With 1.7.3, the first url was getting used and my tests were succeeding. However, with
1.8.0 the second url get's chosen and my tests failed with a "404 Not Found" error.
> See this for more details: http://pastie.org/private/yzxbnvxwidajalcucwflwa



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message