jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Himmat Singh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-645) Incorrect endpoint url chosen for default region of HPCloud Object Storage
Date Tue, 27 Oct 2015 08:51:27 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14976031#comment-14976031
] 

Himmat Singh commented on JCLOUDS-645:
--------------------------------------

'Jcloud'  does not have much cloudstack support.
can you please let me know about, is there any plugin available which supports Ruby and have
Cloudstack Templets in .yml file format it's just like aws Cloudformation templetes (.json
file) which can automate process of creating Vm or can say call all CloudStack API's.  I requesting
u to find out 

> Incorrect endpoint url chosen for default region of HPCloud Object Storage
> --------------------------------------------------------------------------
>
>                 Key: JCLOUDS-645
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-645
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-blobstore
>    Affects Versions: 1.8.0
>            Reporter: Shri Javadekar
>            Assignee: Andrew Gaul
>              Labels: swift
>             Fix For: 2.0.0
>
>
> JClouds seems to be choosing the wrong endpoint from the service catalog returned by
HPCloud Object Storage.
> From what I see there are two endpoints returned in the Object Storage part of the service
catalog.
> D 07-31 13:21:22.122 pool-1-thread-1 jclouds.wire:59 |::] << "          "publicURL":
"https:\/\/region-a.geo-1.objects.hpcloudsvc.com\/v1\/53176293441764",[\n]"
> D 07-31 13:21:22.124 pool-1-thread-1 jclouds.wire:59 |::] << "          "publicURL":
"https:\/\/region-b.geo-1.objects.hpcloudsvc.com\/v1\/53176293441764",[\n]"
> I do not have any region configured.
> With 1.7.3, the first url was getting used and my tests were succeeding. However, with
1.8.0 the second url get's chosen and my tests failed with a "404 Not Found" error.
> See this for more details: http://pastie.org/private/yzxbnvxwidajalcucwflwa



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message