jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ignasi Barrera (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (JCLOUDS-1147) Byon should avoid using deprecated snakeyaml Loader class
Date Tue, 02 Aug 2016 13:49:20 GMT

     [ https://issues.apache.org/jira/browse/JCLOUDS-1147?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ignasi Barrera updated JCLOUDS-1147:
------------------------------------
    Affects Version/s: 1.9.2

> Byon should avoid using deprecated snakeyaml Loader class
> ---------------------------------------------------------
>
>                 Key: JCLOUDS-1147
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-1147
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-compute
>    Affects Versions: 1.9.2, 2.0.0
>            Reporter: Josef Cacek
>              Labels: byon
>             Fix For: 2.0.0
>
>
> The byon API fails to work with newer snakeyaml versions (e.g. when newer snakeyaml dependency
is introduced by other library).
> The error is following.
> {code}
> java.lang.NoClassDefFoundError: org/yaml/snakeyaml/Loader
> {code}
> The problem is, the byon uses snakeyaml version 1.11 which still contains *deprecated*
{{Loader}} class. The functionality provided originally by the {{Loader}} is already directly
in the {{Yaml}} class. The deprecated class was removed in snakeyaml 1.15. The current version
is 1.17.
> I suggest to fix the problem and upgrade the dependency to the latest snakeyaml.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message