jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Phillips (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-1188) ApacheHCHttpCommandExecutorServiceModule should support TLS1.2 only
Date Sat, 22 Oct 2016 14:47:58 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-1188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15597972#comment-15597972
] 

Andrew Phillips commented on JCLOUDS-1188:
------------------------------------------

We should probably fold this into JCLOUDS-759

> ApacheHCHttpCommandExecutorServiceModule should support TLS1.2 only
> -------------------------------------------------------------------
>
>                 Key: JCLOUDS-1188
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-1188
>             Project: jclouds
>          Issue Type: Improvement
>          Components: jclouds-drivers
>    Affects Versions: 1.9.2
>         Environment: All Operating Systems.
>            Reporter: DILEEP DIXITH
>
> Currently SSLContext in ApacheHCHttpCommandExecutorServiceModulesupports only TLS1.0
Protocol.
> https://github.com/jclouds/jclouds/blob/master/drivers/apachehc/src/main/java/org/jclouds/http/apachehc/config/ApacheHCHttpCommandExecutorServiceModule.java
> Due to Various security vulnerabilities, Many Servers supports/enables  only TLS1.2 Protocols.
> ApacheHCHttpCommandExecutorServiceModule Needs change to support TLS1.2 Protocols only.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message