jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ignasi Barrera <notificati...@github.com>
Subject [jclouds/jclouds] Make jclouds compatible with newer OSGi framework versions (#1034)
Date Thu, 03 Nov 2016 08:48:26 GMT
This is based on https://github.com/jclouds/jclouds/pull/1033.

This PR fixes the build of the previous one and makes the OSGi framework version configurable,
so we can run builds for different environments. The scope of the OSGi dependencies is `provided`,
so we can expect target platforms to have different versions than the ones used to build jclouds.

With this change, the build succeeds with the base version, and also with the latest versions:

    mvn clean install -Dosgi.version=6.0.0 -Dosgi.compendium.version=5.0.0
You can view, comment on, or merge this pull request online at:

  https://github.com/jclouds/jclouds/pull/1034

-- Commit Summary --

  * org/jclouds/scriptbuilder/functionloader/osgi/BundleFunctionLoader.java:
  * Make code compatible with newer OSGi framework versions

-- File Changes --

    M core/pom.xml (2)
    M core/src/test/java/org/jclouds/osgi/BundlesTest.java (14)
    M core/src/test/java/org/jclouds/osgi/MetadataBundleListenerTest.java (42)
    M project/pom.xml (12)
    M resources/modernizer_exclusions.txt (1)
    M scriptbuilder/pom.xml (1)
    M scriptbuilder/src/main/java/org/jclouds/scriptbuilder/functionloader/osgi/BundleFunctionLoader.java
(10)

-- Patch Links --

https://github.com/jclouds/jclouds/pull/1034.patch
https://github.com/jclouds/jclouds/pull/1034.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jclouds/jclouds/pull/1034

Mime
View raw message