jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ignasi Barrera (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-1215) Update Bouncycastle from 1.51 to 1.53
Date Wed, 07 Dec 2016 16:32:59 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-1215?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15729186#comment-15729186
] 

Ignasi Barrera commented on JCLOUDS-1215:
-----------------------------------------

The [version of SSHJ|https://github.com/jclouds/jclouds/blob/master/drivers/sshj/pom.xml#L92]
we use in the {{jclouds-sshj}} driver needs Bouncycastle 1.51. I recall having issues when
upgrading Bouncycastle, and as I see, the latest version of SSHJ still uses the same version
of BC.

Would you be able to help us test jclouds with the newer version of BC and SSHJ?

> Update Bouncycastle from 1.51 to 1.53
> -------------------------------------
>
>                 Key: JCLOUDS-1215
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-1215
>             Project: jclouds
>          Issue Type: Improvement
>    Affects Versions: 2.0.0
>            Reporter: Abdysamat Mamutov
>
> It would be nice to update Bouncycastle lib in JClouds project to 1.53 or later versions.
As I see currently version 1.51 is being used: https://github.com/jclouds/jclouds/blob/master/drivers/bouncycastle/pom.xml
> Because of this we have version conflict in our project, we using 1.53 but JClouds 2.0.0
uses 1.51 and we have errors.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message