jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-1246) Extending RegionScopedBlobStore is not possible because of protected access specifier
Date Wed, 01 Mar 2017 19:49:45 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-1246?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15890911#comment-15890911
] 

ASF subversion and git services commented on JCLOUDS-1246:
----------------------------------------------------------

Commit f76c09cbe6b31729f00c213ba6d624da15647cb5 in jclouds's branch refs/heads/2.0.x from
[~archupsg03]
[ https://git-wip-us.apache.org/repos/asf?p=jclouds.git;h=f76c09c ]

JCLOUDS-1246: Allow extending SwiftBlobStoreContextModule


> Extending RegionScopedBlobStore is not possible because of protected access specifier
> -------------------------------------------------------------------------------------
>
>                 Key: JCLOUDS-1246
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-1246
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-blobstore
>    Affects Versions: 2.0.0
>         Environment: RHEL - 7.2
> Java - 1.7
>            Reporter: Archana Chinnaiah
>
> Factories and provider methods in the SwiftBlobStoreContextModule are all package protected
and cannot be easily extended, which does not allow us to create Custom blobstore outside
jClouds



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message