jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Gaul (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (JCLOUDS-1131) jclouds-2.0.0 not compatible with gson-2.7
Date Sat, 22 Apr 2017 20:06:04 GMT

     [ https://issues.apache.org/jira/browse/JCLOUDS-1131?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Gaul updated JCLOUDS-1131:
---------------------------------
    Component/s: jclouds-core

> jclouds-2.0.0 not compatible with gson-2.7
> ------------------------------------------
>
>                 Key: JCLOUDS-1131
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-1131
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-core
>    Affects Versions: 2.0.0
>            Reporter: Olivier Voortman
>
> It seems jclouds is using some of gson internal classes, which is wrong.
> There is now an incompatibility in jclouds-core-2.0.0-SNAPSHOT.jar.
> The class org.jclouds.json.internal.DeserializationConstructorAndReflectiveTypeAdapterFactory
is importing com.google.gson.internal.bind.ReflectiveTypeAdapterFactory which is clearly marked
as internal.
> There is now a 4th parameter on the constructor since gson-2.7.
> Is it something that you can fix, maybe by cloning that ReflectiveTypeAdapterFactory
inside your packages ?
> Thanks.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message