jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Gaul (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (JCLOUDS-1310) Use AWS S3 Transfer Acceleration
Date Sun, 09 Jul 2017 23:02:00 GMT

     [ https://issues.apache.org/jira/browse/JCLOUDS-1310?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Gaul updated JCLOUDS-1310:
---------------------------------
    Issue Type: New Feature  (was: Bug)

> Use AWS S3 Transfer Acceleration
> --------------------------------
>
>                 Key: JCLOUDS-1310
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-1310
>             Project: jclouds
>          Issue Type: New Feature
>          Components: jclouds-blobstore
>    Affects Versions: 2.0.1
>            Reporter: Paya Ashkan
>              Labels: aws-s3
>
> When I enabled S3 Transfer Acceleration on my bucket, it gave me the following endpoint:
> * accelaration-test-11.s3-accelerate.amazonaws.com
> Then when I tried to use it in order to create my BlobStoreContext and BlobStore objects
accordingly and issue an operation, I faced the following error:
> * ... request GET https://accelaration-test-11.s3-accelerate.amazonaws.com/ HTTP/1.1
failed with code 400, error: AWSError{requestId='XX', requestToken='XXX, code='AuthorizationHeaderMalformed',
message='The authorization header is malformed; the region 'accelerate' is wrong; expecting
'us-west-1'', context='{Region=us-west-1, HostId=XXX}'}
> I also tried to configure that via generic S3 but also did not solve the issue.
> My bucket is in us-west-1.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message