jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olaf Flebbe (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (JCLOUDS-1496) Update maven-compiler-plugin for increased JDK compatibility
Date Thu, 11 Apr 2019 20:39:00 GMT

     [ https://issues.apache.org/jira/browse/JCLOUDS-1496?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Olaf Flebbe updated JCLOUDS-1496:
---------------------------------
    Description: 
The maven-compiler-plugin is referenced in the wrong clause of the pom file.
It should be within <project><build><pluginManagement><plugins>.
(See for instance https://maven.apache.org/plugins/maven-compiler-plugin/usage.html )

Otherwise you will see Nullptr Exceptions for instance with JDK11.

For now I propose to only move the plugin and use current version 3.8.0. Increasing the errorprone
module version will trigger a lot of diagnostics in errorprone plugins, which should be dealt
seperately.

Doublechecked: Still compiles with java 1.8 

  was:
The maven-compiler-plugin is referenced in the wrong clause of the pom file.
It should be within <project><build><pluginManagement><plugins>.
(See for instance https://maven.apache.org/plugins/maven-compiler-plugin/usage.html )

Otherwise you will see Nullptr Exceptions for instance with JDK11.

For now I propose to only move the plugin and use current version. Increasing the errorprone
module version will trigger a lot of diagnostics in errorprone plugins, which should be dealt
seperately.


> Update maven-compiler-plugin for increased JDK compatibility 
> -------------------------------------------------------------
>
>                 Key: JCLOUDS-1496
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-1496
>             Project: jclouds
>          Issue Type: Task
>            Reporter: Olaf Flebbe
>            Priority: Major
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> The maven-compiler-plugin is referenced in the wrong clause of the pom file.
> It should be within <project><build><pluginManagement><plugins>.
> (See for instance https://maven.apache.org/plugins/maven-compiler-plugin/usage.html )
> Otherwise you will see Nullptr Exceptions for instance with JDK11.
> For now I propose to only move the plugin and use current version 3.8.0. Increasing the
errorprone module version will trigger a lot of diagnostics in errorprone plugins, which should
be dealt seperately.
> Doublechecked: Still compiles with java 1.8 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message