jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ignacio de Córdoba <icord...@skios.es>
Subject Re: provider softlayer not in supported list: []
Date Fri, 03 Jan 2014 10:07:10 GMT
Thanks Andrew,
I fixed it referencing JClouds module in the META-INF/jboss-deployment-structure.xml with:

<module name="org.jclouds" services="import"/>

And in the module.xml definition, I had to include:
	<dependencies>
		<module name="sun.jdk"/>
		<module name="javax.api"/>
		<module name="javax.xml.bind.api"/>
	</dependencies>


Ignacio de Córdoba
icordoba@skios.es
Red Skios S.A. - www.skios.es



On 3 Jan 2014, at 10:23, Andrew Phillips <andrewp@apache.org> wrote:

>> Caused by: java.lang.IllegalArgumentException: provider softlayer not in supported
list: []
> 
> This is most likely caused by
> 
> a) either a missing provider JAR on your classpath or
> b) lack of support in your context for service provider discovery using ServiceLoader
[1]
> 
> Quickly searching for "ServiceLoader jboss 7" turned up the following links, which might
help:
> 
> http://jbossosgi.blogspot.de/2010/01/suns-serviceloader-and-how-it-relates.html
> https://issues.jboss.org/browse/AS7-4
> 
> Regards
> 
> ap
> 
> [1] http://docs.oracle.com/javase/7/docs/api/java/util/ServiceLoader.html


Mime
View raw message