jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shital Patil <shital.pa...@gslab.com>
Subject Re: Problem connecting to openstack
Date Mon, 03 Feb 2014 05:34:21 GMT
Hi Everett,

I want to clarify few things-

1-I am given an account on openstack but no admin access,
2-Other users have been successfully accessing openstack through curl as
well as  through python library urllib2
3-I can do many things from openstack dashboard ex. launching
instances,listing images etc.
4- I am able to access openstack using curl

I tried doing simple authentication using code over here
http://blog.phymata.com/2013/06/17/jclouds-manual-authentication-with-openstack/
and it threw same exception. This means authentication itself fails in
first place so other operations are just beyond it and hence bound to fail.



Kindly suggest what can be done in this case

Thank you


On Fri, Jan 31, 2014 at 10:56 PM, Everett Toews <everett.toews@rackspace.com
> wrote:

> I can't see anything obviously wrong either.
>
> Shital, are you able to create new tenants and users in your OpenStack
> cloud?
>
> I would suggest creating a tenant simply named "testTenant" that has one
> user "testUser" with an easy password like "testPassword".
>
> If that doesn't work for you, you may need to delve into your Keystone
> logs and configuration.
>
> HTH,
> Everett
>
>
> On Jan 31, 2014, at 10:36 AM, Andrew Phillips <andrewp@apache.org> wrote:
>
> > Hi Shital
> >
> > I can't immediately spot anything obviously wrong. Let's if some of the
> OpenStack experts on the list can find something!
> >
> > ap
>
>

Mime
View raw message