jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From felipe gutierrez <fel...@usto.re>
Subject Re: Error on ContextBuilder.newBuilder("filesystem")
Date Fri, 23 May 2014 13:42:22 GMT
yes >
<dependency>
<groupId>org.apache.jclouds</groupId>
<artifactId>jclouds-blobstore</artifactId>
<version>1.7.2</version>
</dependency>
<dependency>
<groupId>org.apache.jclouds.api</groupId>
<artifactId>filesystem</artifactId>
<version>1.7.2</version>
</dependency>
<dependency>
<groupId>com.google.guava</groupId>
<artifactId>guava</artifactId>
<version>15.0</version>
</dependency>


On Fri, May 23, 2014 at 10:40 AM, Andrew Phillips <andrewp@apache.org>wrote:

> Hi Filipe
>
>
>  Caused by: java.lang.IncompatibleClassChangeError: class
>> com.google.common.cache.CacheBuilder$3 has interface
>> com.google.common.base.Ticker as super class
>>
>
> This indeed also looks like a library incompatibility. Could you list the
> various versions of Google libraries that are on your classpath?
>
> Regards
>
> ap
>

Mime
View raw message