jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Inbar Stolberg <inbar...@gmail.com>
Subject Guava versions
Date Wed, 03 Sep 2014 16:40:38 GMT
Hey all
I know I've been bombarding the forum lately so sorry and thank you for all
the quick replies.

Regarding guava.
Jclouds is using guava 1.7 and is keeping up to date with the guava
versions the problem is not every one does and guava versions are not
backward compatible.
I am using casandara which the latest official release supports guava 1.5
So to make Cassandra and jclouds work in the same module I needed to
downgrade jclouds to 1.6 (meddling in the code) and upgrade Cassandra to a
nun official release version.
I believe this gap will increase over time. And basically it means jclouds
won't provide backward compatibility due to third party jars.
Can any of the devs respond to this issue?

Thanks in advance
Regards inbar

Mime
View raw message