jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yaron Rosenbaum <yaron.rosenb...@gmail.com>
Subject Re: GCE: Unable to create nodes
Date Sun, 22 Mar 2015 08:46:59 GMT
More info:

I tried creating the nodes without specifying ssh login credentials (so that they will be
created automatically), to eliminate a potential problem with the keys I specify. The problem
remains.

I’m pretty much convinced by now, that this is a timeout issue: Because I specify a cloud-init
that takes a while to execute (more than 60000 msec), ssh daemon / ssh keys are not installed
by the time the sshj jcloouds module tries to connect.

There should be some retry / exponential backoff mechanism around the code that tries to configure
new nodes via ssh. As the email below explains, I tried setting some overrides suggested by
someone in the IRC channel, but they seem to do nothing in this case.

Any help would be appreciated!!


(Y)

> On Mar 20, 2015, at 11:51 AM, Yaron Rosenbaum <yaron.rosenbaum@gmail.com> wrote:
> 
> Hi
> 
> I fail to create nodes properly, getting the following error:
> 
> 11:42:32.780 [user thread 3] ERROR jclouds.ssh - << (core:rsa[ssh-agent]@1….2)
error acquiring {hostAndPort=1…2:22, loginUser=core, ssh=null, connectTimeout=60000, sessionTimeout=60000}
(not retryable): Exhausted available authentication methods
> net.schmizz.sshj.userauth.UserAuthException: Exhausted available authentication methods
> 
> I’ve set the following overrides:
> 		overrides.setProperty(ComputeServiceProperties.POLL_INITIAL_PERIOD, TWENTY_SECONDS);
> 		overrides.setProperty(ComputeServiceProperties.POLL_MAX_PERIOD, TWENTY_SECONDS);
> 		// 18 retries of 15 seconds --> 4.5 min
> 		overrides.setProperty(Constants.PROPERTY_MAX_RETRIES, "6"); 
> 		overrides.setProperty(Constants.PROPERTY_RETRY_DELAY_START, "15");
> 
> Note the ’(not retryable)’ and ssh=null, they look suspicious but I don’t know
what they mean.
> 
> PS Nodes are created nonetheless.
> If a node fails to create ‘properly’ - maybe there should be some option to force
remove it or something ?
> 
> (Y)
> 


Mime
View raw message