jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ignasi Barrera <n...@apache.org>
Subject Re: Exception in ExecResponse & SshjSshClient
Date Tue, 22 Mar 2016 09:46:55 GMT
The issue is that it appears that you are adding the version 1.6.0 of
the "jclouds-ssh" dependency. Could you upgrade that to 2.0.0-SNAPSHOT
too?

[INFO] +- org.jclouds.driver:jclouds-sshj:jar:1.6.0:compile
[INFO] |  +- org.jclouds:jclouds-compute:jar:1.6.0:compile
[INFO] |  |  \- org.jclouds:jclouds-scriptbuilder:jar:1.6.0:compile
[INFO] |  +- org.jclouds:jclouds-core:jar:1.6.0:compile
[INFO] |  +- org.jclouds.driver:jclouds-slf4j:jar:1.6.0:compile
[INFO] |  +- org.jclouds.driver:jclouds-bouncycastle:jar:1.6.0:compile



On 22 March 2016 at 10:19, 王逸群 <wyqqrince@gmail.com> wrote:
> hi, the output is shown below:
>
> [INFO] Scanning for projects...
> [INFO]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building EACdemo 1.0-SNAPSHOT
> [INFO]
> ------------------------------------------------------------------------
> [INFO]
> [INFO] --- maven-dependency-plugin:2.8:tree (default-cli) @ ACEdemo ---
> [INFO] wyq-demo:ACEdemo:jar:1.0-SNAPSHOT
> [INFO] +- junit:junit:jar:3.8.1:test
> [INFO] +- org.apache.jclouds:jclouds-all:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.api:rackspace-cloudidentity:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \-
> org.apache.jclouds.api:openstack-keystone:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.api:openstack-cinder:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \- org.apache.jclouds:jclouds-core:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.api:rackspace-clouddns:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.provider:aws-cloudwatch:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \- org.apache.jclouds.api:cloudwatch:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.provider:rackspace-cloudblockstorage-us:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.provider:rackspace-cloudblockstorage-uk:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.provider:rackspace-clouddns-us:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.provider:rackspace-clouddns-uk:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.provider:rackspace-clouddatabases-us:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \-
> org.apache.jclouds.api:openstack-trove:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.provider:rackspace-clouddatabases-uk:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +- org.apache.jclouds.provider:aws-sqs:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \- org.apache.jclouds.api:sqs:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +- org.apache.jclouds.provider:aws-sts:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \- org.apache.jclouds.api:sts:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.provider:aws-route53:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \- org.apache.jclouds.api:route53:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds.provider:ultradns-ws:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +- org.apache.jclouds.provider:dynect:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +- org.apache.jclouds.api:chef:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds:jclouds-scriptbuilder:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \-
> com.google.inject.extensions:guice-multibindings:jar:3.0:compile
> [INFO] |  +-
> org.apache.jclouds:jclouds-allloadbalancer:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:rackspace-cloudloadbalancers-uk:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  |  +-
> org.apache.jclouds:jclouds-loadbalancer:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  |  \-
> org.apache.jclouds.api:rackspace-cloudloadbalancers:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \-
> org.apache.jclouds.provider:rackspace-cloudloadbalancers-us:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  +-
> org.apache.jclouds:jclouds-allcompute:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:aws-ec2:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.api:openstack-nova:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  |  \-
> org.apache.jclouds:jclouds-compute:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.api:openstack-nova-ec2:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +- org.apache.jclouds.api:byon:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  |  \- org.yaml:snakeyaml:jar:1.11:compile
> [INFO] |  |  +- org.apache.jclouds.api:ec2:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:gogrid:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.api:elasticstack:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:elastichosts-lon-p:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:elastichosts-sat-p:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:elastichosts-lon-b:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:openhosting-east1:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:serverlove-z1-man:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:skalicloud-sdg-my:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:go2cloud-jhb1:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:softlayer:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +- org.apache.jclouds.api:cloudstack:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:rackspace-cloudservers-us:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:rackspace-cloudservers-uk:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:google-compute-engine:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  |  \-
> org.apache.jclouds.common:googlecloud:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  +-
> org.apache.jclouds.provider:digitalocean2:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  |  \- org.apache.jclouds.api:oauth:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  |  \-
> org.apache.jclouds.provider:profitbricks:jar:2.0.0-SNAPSHOT:compile
> [INFO] |  \-
> org.apache.jclouds:jclouds-allblobstore:jar:2.0.0-SNAPSHOT:compile
> [INFO] |     +- org.apache.jclouds.api:s3:jar:2.0.0-SNAPSHOT:compile
> [INFO] |     |  +- com.jamesmurty.utils:java-xmlbuilder:jar:1.1:compile
> [INFO] |     |  |  \- net.iharder:base64:jar:2.3.8:compile
> [INFO] |     |  \-
> org.apache.jclouds:jclouds-blobstore:jar:2.0.0-SNAPSHOT:compile
> [INFO] |     +-
> org.apache.jclouds.provider:aws-s3:jar:2.0.0-SNAPSHOT:compile
> [INFO] |     +-
> org.apache.jclouds.provider:azureblob:jar:2.0.0-SNAPSHOT:compile
> [INFO] |     +- org.apache.jclouds.api:atmos:jar:2.0.0-SNAPSHOT:compile
> [INFO] |     +-
> org.apache.jclouds.api:openstack-swift:jar:2.0.0-SNAPSHOT:compile
> [INFO] |     +-
> org.apache.jclouds.provider:rackspace-cloudfiles-us:jar:2.0.0-SNAPSHOT:compile
> [INFO] |     |  \-
> org.apache.jclouds.api:rackspace-cloudfiles:jar:2.0.0-SNAPSHOT:compile
> [INFO] |     \-
> org.apache.jclouds.provider:rackspace-cloudfiles-uk:jar:2.0.0-SNAPSHOT:compile
> [INFO] +- org.slf4j:slf4j-simple:jar:1.6.1:compile
> [INFO] |  \- org.slf4j:slf4j-api:jar:1.6.1:compile
> [INFO] +- org.jclouds.driver:jclouds-sshj:jar:1.6.0:compile
> [INFO] |  +- org.jclouds:jclouds-compute:jar:1.6.0:compile
> [INFO] |  |  \- org.jclouds:jclouds-scriptbuilder:jar:1.6.0:compile
> [INFO] |  +- org.jclouds:jclouds-core:jar:1.6.0:compile
> [INFO] |  |  +- javax.ws.rs:jsr311-api:jar:1.1.1:compile
> [INFO] |  |  +-
> com.google.inject.extensions:guice-assistedinject:jar:3.0:compile
> [INFO] |  |  +- com.google.inject:guice:jar:3.0:compile
> [INFO] |  |  |  \- aopalliance:aopalliance:jar:1.0:compile
> [INFO] |  |  +- org.99soft.guice:rocoto:jar:6.2:compile
> [INFO] |  |  +- javax.inject:javax.inject:jar:1:compile
> [INFO] |  |  +- javax.annotation:jsr250-api:jar:1.0:compile
> [INFO] |  |  \- com.google.code.gson:gson:jar:2.2.2:compile
> [INFO] |  +- org.jclouds.driver:jclouds-slf4j:jar:1.6.0:compile
> [INFO] |  +- org.jclouds.driver:jclouds-bouncycastle:jar:1.6.0:compile
> [INFO] |  |  \- org.bouncycastle:bcprov-jdk16:jar:1.46:compile
> [INFO] |  \- net.schmizz:sshj:jar:0.8.1:compile
> [INFO] +- com.google.guava:guava:jar:19.0:compile
> [INFO] \- de.hhu.stups:probkodkod:jar:1.0.3:compile
> [INFO]    +- org.ow2.sat4j:org.ow2.sat4j.core:jar:2.3.5:compile
> [INFO]    \- de.hhu.stups:prologlib:jar:2.4.40:compile
> [INFO]       \- com.google.code.findbugs:jsr305:jar:1.3.9:compile
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 1.288 s
> [INFO] Finished at: 2016-03-22T17:18:28+08:00
> [INFO] Final Memory: 15M/212M
> [INFO]
> ------------------------------------------------------------------------
>
> Best Regards,
> Yiqun Wang
>
>
> Ignasi Barrera <nacx@apache.org>于2016年3月22日周二 下午5:14写道:
>>
>> It looks like you could have a mix of versions in your classpath.
>> Could you share the output of running the "mvn dependency:tree"
>> command in the root of *your* project?
>>
>>
>> I.
>>
>> On 22 March 2016 at 09:25, 王逸群 <wyqqrince@gmail.com> wrote:
>> > Hi,
>> >     I intend to use SshClient to execute some scripts. The codes can be:
>> >
>> >     SshClient sshClient = sshFactory.create()...;
>> >     sshClient.connect();
>> >     String rawScript = "echo 1";
>> >     ExecResponse result = sshClient.exec(rawScirpt);
>> >
>> >     Then I got an error in the last line, the stack is here:
>> >
>> > java.lang.NoSuchMethodError:
>> >
>> > org.jclouds.compute.domain.ExecResponse.<init>(Ljava/lang/String;Ljava/lang/String;I)V
>> > at
>> >
>> > org.jclouds.sshj.SshjSshClient$ExecConnection.create(SshjSshClient.java:452)
>> > at
>> >
>> > org.jclouds.sshj.SshjSshClient$ExecConnection.create(SshjSshClient.java:429)
>> > at org.jclouds.sshj.SshjSshClient.acquire(SshjSshClient.java:193)
>> > at org.jclouds.sshj.SshjSshClient.exec(SshjSshClient.java:465)
>> > at chef.ChefTool.install(ChefTool.java:221)
>> > at chef.ChefTool.main(ChefTool.java:158)
>> > 4446 [main] INFO net.schmizz.sshj.transport.TransportImpl - Disconnected
>> > -
>> > BY_APPLICATION
>> > SSH closed.
>> >
>> >       I could execute the certain script when using earlier version, I
>> > wonder if it contains a bug here. My jclouds version is 2.0.0-SNAPSHOT.
>> >       Thanks for your help!
>> >
>> > Best Regards,
>> > Yiqun Wang

Mime
View raw message