jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ignasi Barrera <n...@apache.org>
Subject Re: ApacheHC need yo support TLS1.2
Date Sat, 22 Oct 2016 06:47:50 GMT
Hi Dileep,

Mind opening an issue in our JIRA? That is the best way to keep track of
this.

I can't tell when the patch will be available, but the best way to make
sure it happens soon is contributing and opening a pull request :) If you
are up to do it, I will be happy to help and provide guidace.

I.

On Oct 22, 2016 08:30, "Dileep Dixith" <didixith@in.ibm.com> wrote:

> Hi,
>
> Currently SSLContext in *ApacheHCHttpCommandExecutorServiceModule*supports
> only TLS1.0 Protocol.
>
> https://github.com/jclouds/jclouds/blob/master/drivers/
> apachehc/src/main/java/org/jclouds/http/apachehc/config/
> ApacheHCHttpCommandExecutorServiceModule.java
>
> Due to Various security vulnerabilities, Many Servers supports/enables
>  only TLS1.2 Protocols.
>
> *ApacheHCHttpCommandExecutorServiceModule* Needs change to support TLS1.2
> Protocols only.
>
> Let me know when this changes will be ready.
>
> Regards,
> ------------------------------
> *Dileep Dixith*
>  Bangalore, 560071
> Security Developer, Big Storage and MCStore  India
>
> IBM Systems & Technology Lab
> +91-80-41776741
> Mobile: +91-95-91345900
> e-mail: didixith@in.ibm.com
> ------------------------------
>
>
>

Mime
View raw message