jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Turli <andrea.tu...@gmail.com>
Subject Re: JSR311 outdated dependency
Date Tue, 25 Jul 2017 16:52:31 GMT
Hi Pavel,

which jclouds version are you using?
For sure master bumped the version of that dependency, see
https://github.com/jclouds/jclouds/pull/1057 for more details.

Let us know if that's solve your issue. If so it will be available in the
next jclouds releases starting from 2.1.0

Il 25/lug/2017 17:29, "Pavel Micka" <Pavel.Micka@zoomint.com> ha scritto:

> Hi,
>
>
>
> Would it be possible to use new implementation of this specification? The
> version used (https://mvnrepository.com/artifact/javax.ws.rs/jsr311-
> api/1.1.1) is from year 2009 and it causes us troubles to compile against
> jClouds. Specifically we have problems with this class:
>
> http://docs.oracle.com/javaee/6/api/javax/ws/rs/core/MultivaluedMap.html
>
> where one of our testing libraries Docker-Client by Spotify requires
> method addAll, which was added in Java EE 7
>
> http://docs.oracle.com/javaee/7/api/javax/ws/rs/core/MultivaluedMap.html
>
>
>
> Thanks!
>
>
>
> Pavel
>

Mime
View raw message