jena-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Seaborne <>
Subject Re: issues building TxTDB
Date Mon, 14 Nov 2011 22:02:01 GMT
ARQ is not up-to-date in your local repo att he time of the TDB test suite.

I saw the same as you during today on the Apache build server but it was 
because I'd only put an install of ARQ locally, not deployed it. 
Locally, TDB test suite worked, but broke on the Apache build server.

When I deployed the latest snapshot ARQ, TDB was fine.

Broken build: #336

Working build: #338

You can get the commits and Jenkins build failures on mailing list 

Or see the Jenkins development build is tracked at:
which has an RSS feed.

Try svn updating ARQ, installing that, then doing "mvn clean test" (and 
also deleting the tmp/testing directory and everything under it).  I 
find "clean" is sometimes necessary as junk class files seem to get left 
around.  Compiling is quick enough.


On 14/11/11 21:17, Simon Helsen wrote:
> Hi guys,
> I just updated everything in my SVN projects and started to maven build
> everything in my sequence (TopJena,IRI,Jena2,ARQ,TxTDB), using the maven
> command-line (i.e. outside eclipse)
> This went fine up until the TxTDB which repeated fails with test errors.
> Moreover, repeated attempts (I run 'mvn install') also produce different
> test errors. I am running this on a Windows 7/64 bit machine
> anyone seen this?
> Simon

View raw message