jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philippe Mouawad <philippe.moua...@gmail.com>
Subject Re: ISSUE 53348
Date Sun, 03 Jun 2012 19:38:34 GMT
Hello,
I made different tests and I can confirm that whenever Request and Receive
Queue do not point to same Queue, we will get  a failure :

   - Response message: No reply message received

It seems logical to me looking at code but is it was what expected from
this feature ?

Thanks

Regards

Philippe
On Sun, Jun 3, 2012 at 5:03 PM, Philippe Mouawad <philippe.mouawad@gmail.com
> wrote:

> Hello,
> Analysing issue https://issues.apache.org/bugzilla/show_bug.cgi?id=53348,
> I think there is something missing in documentation, but as I don't have
> all history I have a question regarding it.
> Looking at JMeter code, I think that when Request Response mode is used,
> there need to be a request handler somewhere outside of JMeter that will
> use replyTO header to send a message to reply queue.
>
> So issue submitted is not a real one.
> But in component_reference.html , this point is not clear at all, except
> that in example same queue is used for request and response so it works.
> and in user manuel build-jms-point-to-point-test-plan.html, it is only
> said in 11.2 paragraph for property :
>
>    - Communication Style  / Request Response / This means that you need
>    at least a service that responds to the requests.
>
>
> If I am not missing something, then I will clarify documentation on these
> points.
> Otherwise please let me know if I am missing something.
>
> --
> Regards.
> Philippe
>
>
>


-- 
Cordialement.
Philippe Mouawad.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message