jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philippe Mouawad <philippe.moua...@gmail.com>
Subject Re: Release a 3.0
Date Sun, 03 Jan 2016 15:08:45 GMT
Hi Felix,
Thanks for answer.
I don't think it will be a long hold on the new release, for me we have
these remaining points:

   - Integrate HTTPCLIENT 4.5.2 to fix
   - 58583 <https://bz.apache.org/bugzilla/show_bug.cgi?id=58583>
      - 57319
   - Finalize tests
   - 57804 => Waiting confirmation from Rainer or any other member of the
      team
      - Deprecation:
      - 58791 => I will do it
      - Not mandatory but would be nice:
      - 58793
      - 58790
      - 58792 => I will try to stat it
      - 58794 => I will start a discussion on this


That's all for me, but if you see other things feel free to add it.

Thanks

Regards

Philippe M.

@philmdot

On Sun, Jan 3, 2016 at 3:37 PM, Felix Schumacher <
felix.schumacher@internetallee.de> wrote:

> Am 01.01.2016 um 19:14 schrieb Philippe Mouawad:
>
>> Hi,
>> Happy new year to the whole team.
>>
>> Any news on this ?
>>
> I have nothing against a 3.0, but I would not like it, if the "big"
> version change would lead to a long hold up of a new release.
>
> Regards,
>  Felix
>
> Thanks
>>
>> On Tue, Dec 29, 2015 at 5:19 PM, Philippe Mouawad <
>> philippe.mouawad@gmail.com> wrote:
>>
>> Hi,
>>> Following my proposals to deprecate a certain number of elements that
>>> were
>>> approved by 2 commiters and knowing that we have some important new
>>> features in this release, I propose to name next version 3.0 instead of
>>> 2.14.
>>> It would be the occasion to make a big cleanup in all "oldies" elements
>>> and maybe be even more aggressive in the deprecations/removals.
>>>
>>> And starting from there change our release naming to follow this:
>>> - http://semver.org/
>>>
>>>
>>> This has been mentioned by this thread and I think it's a good idea:
>>> -
>>>
>>> http://mail-archives.apache.org/mod_mbox/jmeter-dev/201411.mbox/%3CCAFJ7uesG%2BsKiQh_wQ5_iLp%3DJ%2BtSiG5fQ%3D7Pp1CvbJ1kncXo%2B%3Dg%40mail.gmail.com%3E
>>>
>>> I think in the developers thinking our current naming is not great, cause
>>> one can think every "major" release we do is a Minor release.
>>>
>>> --
>>> Regards
>>> Philippe M.
>>> @philmdot
>>>
>>>
>>>
>>
>


-- 
Cordialement.
Philippe Mouawad.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message