jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milamber <milam...@apache.org>
Subject [CANCELLED] JMeter 3.1 RC1
Date Sat, 05 Nov 2016 17:00:47 GMT
I've cancelled the 3.1 RC1 because some new images are missing from the 
docs directory and the intro.xml file have been deleted in xdocs but not 
in docs.
(I've forget to check the svn tree before tagging the rc branch)

I will start the RC2 now.


========

Hello,

The first release candidate for JMeter 3.1 (r1768226) has been prepared, 
and your votes are solicited.

This release brings new features and fixes bugs.

Please, test this release candidate (with load tests and/or functional 
tests) using Java 7/8 on Linux/Windows/Mac OS, especially on the 
changes. The feedback are welcome.

You can read the New and Noteworthy section with some screenshots to 
illustrate improvements and full list of changes at:
http://home.apache.org/~milamber/jmeter-3.1RC1/docs/changes.html

JMeter is a Java desktop application designed to load test functional 
behavior and measure performance. The current version is targeted at 
Java 7+.

Download - Archives/hashes/sigs:

https://dist.apache.org/repos/dist/dev/jmeter/v3.1_RC1/
(dist revision r16847)

RAT report:

http://home.apache.org/~milamber/jmeter-3.1RC1/dist/rat-report-jmeter-3.1RC1.txt

MD5 hashes of archives for this vote:

1dca885cb4c6d1ed6224dd0bd2b42287 *apache-jmeter-3.1.tgz
de5bf9d3903bee6e84dce2dac9b64320 *apache-jmeter-3.1.zip
09bca4639c695719b4df143c69fb0d1b *apache-jmeter-3.1_src.tgz
b78181c5f549319e9480b2fef60fb96f *apache-jmeter-3.1_src.zip


Site Docs are here:
http://home.apache.org/~milamber/jmeter-3.1RC1/docs/

Maven staging repository is accessible here:
https://repository.apache.org/content/repositories/orgapachejmeter-1011/org/apache/jmeter/

Tag:
https://svn.apache.org/repos/asf/jmeter/tags/v3_1_RC1/

Keys are here:
https://www.apache.org/dist/jmeter/KEYS

N.B.
To download the dependencies: "ant download_jars"

To create the jars and test JMeter: "ant package test".

JMeter 3.1 requires Java 7 or later to run.

Some known issues and incompatible changes are listed on changes page.
http://home.apache.org/~milamber/jmeter-3.1RC1/docs/changes.html#Known%20problems%20and%20workarounds


All feedback and vote are welcome.
	
[  ] +1  I support this release
[  ] +0  I am OK with this release
[  ] -0   OK, but....
[  ] -1   I do not support this release (please indicate why)

The vote will remain open for at least 72 hours.

The PMC members please indicate the mention "(binding)" with your vote.


Note: If the vote passes, the intention is to release the archive files
and rename the RC tag as the release tag.

Thanks in advance!

Milamber






Mime
View raw message