jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From matheuscunha <...@git.apache.org>
Subject [GitHub] jmeter pull request #315: Fixing bin/jmeter.sh version error, working as exp...
Date Thu, 05 Oct 2017 17:45:39 GMT
GitHub user matheuscunha opened a pull request:

    https://github.com/apache/jmeter/pull/315

    Fixing bin/jmeter.sh version error, working as expected with Oracle J…

    Java 9 and OpenJDK 9. New binary from Java HotSpot just displays java version "9" which
was breaking service initialization.
    
    `+ MINIMAL_VERSION=1.8.0
    ++ awk '{ print $ NF }'
    ++ type java
    + _java=/usr/bin/java
    ++ /usr/bin/java -version
    ++ awk '-F"' '/version/ {print $2}'
    + CURRENT_VERSION=9
    ++ echo 1.8.0
    ++ awk -F. '{ print $2 }'
    + minimal_version=8
    ++ echo 9
    ++ awk -F. '{ print $2 }'
    + current_version=
    + '[' ']'
    + echo 'Not able to find Java executable or version. Please check your Java installation.'
    Not able to find Java executable or version. Please check your Java installation.
    + exit 1`
    
    As you can see, current_version is empty, and can't be checked.
    
    Java version return:
    `java version "9"
    Java(TM) SE Runtime Environment (build 9+181)
    Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode)`

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/matheuscunha/jmeter trunk

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/jmeter/pull/315.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #315
    
----
commit 6bb3b1d5fcd0339630238498b0aebfa0ef24ed77
Author: Matheus Cunha <matheuz.a@gmail.com>
Date:   2017-10-05T17:40:23Z

    Fixing bin/jmeter.sh version error, working as expected with Oracle Java 9 and OpenJDK
9. New binary from Java HotSpot just displays java version "9" which was breaking service
initialization

----


---

Mime
View raw message