jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From FSchumacher <...@git.apache.org>
Subject [GitHub] jmeter issue #390: Update mongo-java-driver version
Date Sat, 30 Jun 2018 15:33:40 GMT
Github user FSchumacher commented on the issue:

    https://github.com/apache/jmeter/pull/390
  
    Thanks for your contribution, but I don't think this is the correct solution.
    If we only update the jars, the code will not compile anymore. There are a lot of missing
and deprecated methods and classes. I tried to update our usage of the api to the current
one, but that is not possible without a lot of work. (The authentication mechanism has changed
and the eval mechanism, that we depend on has been deprecated/removed).
    As the mongo sampler has been deprecated with JMeter 3.0. So a better patch would be to
remove the client jars altogether.


---

Mime
View raw message