jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vladimir Sitnikov <sitnikov.vladi...@gmail.com>
Subject Re: [jmeter] branch master updated: build.gradle.kts in core, functions, components, protocol: Fix dependencies for pom generation and remove version
Date Sat, 09 Nov 2019 21:45:14 GMT
>implementation("xpp3:xpp3_min")
>Used by core  for persisting

This is very simple to check.
xpp3_min-1.1.4c.jar jar contains only org/xmlpull/... classes.

$ git grep xmlpull
checksum.xml:    <dependency group='xmlpull' module='xmlpull'
version='1.1.3.1'>
gradle.properties:xmlpull.version=1.1.3.1
lib/aareadme.txt:xmlpull-1.1.3.1
lib/aareadme.txt:http://www.xmlpull.org/impls.shtml
src/bom/build.gradle.kts:        apiv("xmlpull:xmlpull")

That is it. JMeter source code does not use org.xmlpull. classes, so
xpp3:xpp3_min dependency should not be added.
The same thing is for other dependencies.

Please revert the changes that add the dependencies.

Vladimir

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message