johnzon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konrad Windszus (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (JOHNZON-108) Add dynamic ServiceLoader support for OSGi environments
Date Fri, 07 Jul 2017 16:46:00 GMT

    [ https://issues.apache.org/jira/browse/JOHNZON-108?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16078369#comment-16078369
] 

Konrad Windszus edited comment on JOHNZON-108 at 7/7/17 4:45 PM:
-----------------------------------------------------------------

If it has been applied on master, is it already contained in some released version? At least
version 1.1.1 has been released afterwards and this indeed seems to contain this fix (https://github.com/apache/johnzon/blob/v1.1.1/johnzon-core/pom.xml#L44).
Can someone set the fix version accordingly?


was (Author: kwin):
If it has been applied on master, is it already contained in some released version? At least
version 1.1.1 has been released afterwards. Can someone set the fix version accordingly?

> Add dynamic ServiceLoader support for OSGi environments
> -------------------------------------------------------
>
>                 Key: JOHNZON-108
>                 URL: https://issues.apache.org/jira/browse/JOHNZON-108
>             Project: Johnzon
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: 1.0.0
>            Reporter: Stefan Seifert
>
> Johnzon 1.0.0 together with org.apache.geronimo.specs:geronimo-json_1.0_spec:1.0-alpha-1
currently does not work within OSGi envrionments - the service loader does not found the implementation
class (see GERONIMO-6560).
> the OSGi spec compliant way for supporting ServiceLoaders is described in the [OSGi Enterprise
Specification|http://www.osgi.org/Download/Release5] (from version 5) chapter 133. [Aries
SPI Fly|http://aries.apache.org/modules/spi-fly.html] is the reference implementation which
also contains a good summary of the steps to make a bundle compatible.
> concerning johnzon-core (provider bundle) we only need to add two bundle headers {{Require-Capability}}
and {{Provide-Capability}} for the SPI {{javax.json.spi.JsonProvider}}.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message