johnzon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Rathgeb <maggu2...@gmail.com>
Subject Johnzon JSON-B on OSGi
Date Fri, 13 Sep 2019 12:39:28 GMT
Hi,

I know that's the dev mailing list, but there is no user one.
So please allow me to comment here.
If there is a better place, please point me in the right direction.

I would like to use johnzon-jsonb 1.1.12 in an OSGi container.

After adding johnzon-jsonb I got:
osgi.wiring.package: (&(osgi.wiring.package=javax.json.bind))

That's easy, we need the respective API bundle.
I added org.apache.geronimo.specs/geronimo-jsonb_1.0_spec/1.1

johnzon-jsonb requires: osgi.contract: (&(osgi.contract=JavaCDI)(version=2.0.0))
I added org.apache.geronimo.specs/geronimo-jcdi_2.0_spec/1.1
This bundle provides the JavaCDI contract version 2.0.0

The jcdi bundle requires: osgi.wiring.package: (&(osgi.wiring.package=javax.el))
I added org.apache.geronimo.specs/geronimo-el_2.2_spec/1.1

The jcdi also requires: osgi.wiring.package:
(&(osgi.wiring.package=javax.inject))
I added org.apache.geronimo.specs/geronimo-atinject_1.0_spec/1.1

The jcdi also requires: osgi.serviceloader:
(osgi.serviceloader=javax.enterprise.inject.se.SeContainerInitializer)

I don't know which bundle provides that service loader.

Can you please point me to a set of bundles to use Johnzon JSON-B in OSGi?

Best regards,
Markus

Mime
View raw message