juddi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "SourceForge.net" <nore...@sourceforge.net>
Subject [juddi-Developers] [ juddi-Bugs-813172 ] find_business fails with nonames search
Date Fri, 26 Sep 2003 12:19:05 GMT
Bugs item #813172, was opened at 2003-09-26 10:01
Message generated for change (Comment added) made by anou_mana
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=434422&aid=813172&group_id=42875

Category: None
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Andriy Vyedyeneyev (anved)
Assigned to: Nobody/Anonymous (nobody)
Summary: find_business fails with nonames search

Initial Comment:
I have tried to find all business, that have references to 

tModel categories. This is SOAP request:



POST /juddi/inquiry HTTP/1.0



Content-Type: text/xml; charset=utf-8



Accept: application/soap+xml, application/dime, 

multipart/related, text/*



User-Agent: Axis/1.0



Host: localhost



Cache-Control: no-cache



Pragma: no-cache



SOAPAction: ""



Content-Length: 627







<?xml version="1.0" encoding="UTF-8"?>

<soapenv:Envelope 

xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelo

pe/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" 

xmlns:xsi="http://www.w3.org/2001/XMLSchema-

instance">

 <soapenv:Body><find_business generic="2.0" 

xmlns="urn:uddi-

org:api_v2"><findQualifiers><findQualifier>orAllKeys</find

Qualifier></findQualifiers><tModelBag><tModelKey>uuid:4

F310BB0-F03B-11D7-8BB0-

9A459BE74E31</tModelKey><tModelKey>uuid:4F38ACD0-

F03B-11D7-ACD0-

CD4BBA66F194</tModelKey><tModelKey>uuid:4F404DF0-

F03B-11D7-8DF0-

9815318A82BE</tModelKey></tModelBag></find_business

> </soapenv:Body>

</soapenv:Envelope>





The response from JUDDI was following:



HTTP/1.1 500 Internal Server Error



Content-Type: text/xml; charset=utf-8



Date: Fri, 26 Sep 2003 16:57:37 GMT



Server: Apache Coyote/1.0



Connection: close







<?xml version="1.0" encoding="UTF-8"?>

<soapenv:Envelope 

xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelo

pe/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" 

xmlns:xsi="http://www.w3.org/2001/XMLSchema-

instance">

 <soapenv:Body>

  <soapenv:Fault>

   <faultcode>soapenv:Server.userException</faultcode>

   

<faultstring>java.lang.NullPointerException</faultstring>

   <detail/>

  </soapenv:Fault>

 </soapenv:Body>

</soapenv:Envelope>





I thought this is because of absence in the request 

name parameter(s). If it's so, i think this is worth thing 

to fix, because UDDIv2 specification defines name as 

optional attribute for this type of UDDI call.





----------------------------------------------------------------------

>Comment By: Anou Manavalan (anou_mana)
Date: 2003-09-26 12:16

Message:
Logged In: YES 
user_id=635638

The no name should not fail, since the code checks for the 

name and ignores it if it is not there.



Could you give more information on which code base it is ? 

and also the log file with debug info in it.



-Anou

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=434422&aid=813172&group_id=42875


Mime
View raw message