juddi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Cunningham <tcunn...@redhat.com>
Subject Re: juddi-tomcat reference
Date Wed, 04 Feb 2009 20:56:25 GMT
So here's where we are as of now :

(2) is solved.     We're now using the maven-dependency-plugin's copy 
mojo rather than using the maven-antrun-plugin to grab the juddi-tomcat 
dependency zip.     That seems to work well locally.

We've still got our fingers crossed on the other issue - which is the 
installation of the juddi-tomcat zip into the repository.      Locally 
it works.      If I install continuum locally and use the same 
maven/java VM, it still works locally.     But it's not working on 
vmbuild.        What's weird is that it doesn't seem to actually install 
the zip that it builds here :

[INFO] Building zip: 
/home/continuum/data/working-directory/1790/target/juddi-tomcat-3.0.0.SNAPSHOT.zip

into the repository :

[INFO] [install:install]
[INFO] [MAVEN-CORE-IT-LOG] Using output file path: 
target/install-install.txt
[INFO] [MAVEN-CORE-IT-LOG] Creating output file: 
/home/continuum/data/working-directory/1790/target/install-install.txt
[INFO] [MAVEN-CORE-IT-LOG] Created output file: 
/home/continuum/data/working-directory/1790/target/install-install.txt



Kurt T Stam wrote:
> Hi Tom,
>
> https://issues.apache.org/jira/browse/JUDDI-174 seems to be resolved, 
> however the juddi-tomcat dependence problem seems back now.
>
> With maven 2.0.8 I locally see:
>
> 1. success build from the uddi-client directory
>
> 2. failed build when running from the parent pom, can't resolve the 
> juddi-tomcat dependency reference.
>
> On the build machine:
>
> It can download the juddi-tomcat artifact from any repo. But it should 
> be able to find it from it's local repo right?
>
> I saw you worked till late on this. Are you seeing the same issues and 
> are you still working on it?
>
> --K
>
>


Mime
View raw message