kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jay Kreps <jay.kr...@gmail.com>
Subject Re: problems on ubuntu
Date Thu, 20 Oct 2011 15:38:56 GMT
Filed https://issues.apache.org/jira/browse/KAFKA-164 for this.

-Jay

On Thu, Oct 20, 2011 at 7:56 AM, Jay Kreps <jay.kreps@gmail.com> wrote:

> This is a good point. I recommend we change the default to something higher
> and set time-based flush to 1 sec.
>
> -Jay
>
>
> On Thu, Oct 20, 2011 at 7:09 AM, Tim Lossen <tim@lossen.de> wrote:
>
>> ok, never mind, we found the culprit. the default server config
>> contains the following setting:
>>
>> > #the number of messages to accept without flushing the log to disk
>> > log.flush.interval=1
>>
>> we changed this value to 10000 now, and the performance is excellent.
>> maybe not the most sensible default value?
>>
>> cheers
>> tim
>>
>>
>> On 2011-10-20, at 11:00 , Tim Lossen wrote:
>>
>> > hello,
>> >
>> > we have been playing around with kafka the last few days, and on
>> > our developer machines (osx 10.6) everythings looks fine. but on
>> > linux (ubuntu 11.04) we get very strange behaviour:
>> >
>> > - the producer seems to get stuck after a few thousand messages
>> > - the consumer seems to run very slowly
>> >
>> > (kafka 0.6, java 1.6.0, default server + zookeeper configuration,
>> > simple producer and consumer scripts written in ruby -- everything
>> > running on same machine.)
>> >
>> > maybe there is something wrong with the os-level network config?
>> > other ideas? any hints / suggestions welcome.
>> >
>> > cheers
>> > tim
>> >
>> > --
>> > http://tim.lossen.de
>> >
>> >
>> >
>>
>> --
>> http://tim.lossen.de
>>
>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message