kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jun Rao <jun...@gmail.com>
Subject Re: Quickstart Problem re: Zookeeper
Date Thu, 15 Dec 2011 04:28:33 GMT
Russell,

We have moved to Apache. Please find the current code at
http://incubator.apache.org/kafka/ . We should be releasing the 0.7 version
soon.

Thanks,

Jun

On Wed, Dec 14, 2011 at 6:53 PM, Russell Jurney <russell.jurney@gmail.com>wrote:

> I'm having a problem with step 1 of the Quickstart guide at
> http://incubator.apache.org/kafka/quickstart.html using code from github:
> https://github.com/kafka-dev/kafka.git
>
> russell-jurneys-macbook-pro:kafka rjurney$ bin/zookeeper-server-start.sh
> config/zookeeper.properties
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/log4j/Logger
> at
>
> org.apache.zookeeper.server.quorum.QuorumPeerMain.<clinit>(QuorumPeerMain.java:62)
> Caused by: java.lang.ClassNotFoundException: org.apache.log4j.Logger
> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> ... 1 more
>
>
> What am I doing wrong?  I tried adding commons logging to my CLASSPATH, but
> it doesn't help.
>
> Thanks,
>
> --
> Russell Jurney
> twitter.com/rjurney
> russell.jurney@gmail.com
> datasyndrome.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message