kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David DeMaagd <ddema...@linkedin.com>
Subject Re: FW: Zookeeper Configuration Question
Date Mon, 10 Dec 2012 16:30:19 GMT
If you're using the zkCli.sh, something like this will create the
namespace:

[zk: localhost:12913(CONNECTED) 1] create /namespace ''
Created /namespace

If you're using another interface, the actual command may vary. 

-- 
Dave DeMaagd
ddemaagd@linkedin.com | 818 262 7958

(Casey.Sybrandy@Six3Systems.com - Mon, Dec 10, 2012 at 01:49:32PM +0000)
> Apologies for not responding sooner.  My mail client must have been malfunctioning at
the time as I never saw your responses until today.
> 
> As for the error, it looks like it's a bug on my part that just didn't click until I
read Jim's responses.  I have a config file that I specify the options in and I copied it
from a Configuration object to a Properties object, as the producer/consumer requires.  Didn't
realize until this morning that it was not working as expected.
> 
> On a different note: does anyone know how to create a namespace in Zookeeper?  We're
having some issues I'm trying to debug so I want to isolate some of our brokers, but finding
documentation on this has been fruitless.
> 
> Thanks!
> ________________________________________
> From: Neha Narkhede [neha.narkhede@gmail.com]
> Sent: Thursday, November 29, 2012 4:39 PM
> To: users@kafka.apache.org
> Subject: Re: FW: Zookeeper Configuration Question
> 
> Please can you send around the log that shows the zookeeper connection
> error ? I would like to see if it fails at connection establishment or
> session establishment.
> 
> Thanks,
> Neha
> 
> On Thu, Nov 29, 2012 at 1:19 PM, James A. Robinson
> <jim.robinson@stanford.edu> wrote:
> > On Thu, Nov 29, 2012 at 1:15 PM, James A. Robinson
> > <jim.robinson@stanford.edu> wrote:
> >> For my kafka startup I point to the zookeeper "cluster" like so:
> >>
> >>   --kafka-zk-connect logproc-dev-03:2181,logproc-dev-03:2182,logproc-dev-03:2183
> >
> > Sorry, wrong copy and paste!  For the kafka startup I point to the zookeeper
> > cluster like so (in the properties file):
> >
> > zk.connect=logproc-dev-03.highwire.org:2181,logproc-dev-03.highwire.org:2182,logproc-dev-03.highwire.org:2183

Mime
View raw message