kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Alexander <calexan...@gravycard.com>
Subject Re: Unable To Run QuickStart From CLI
Date Thu, 20 Dec 2012 15:28:16 GMT
Thanks Jun and Joel. I've got my Kafka development instance up and running. I do have a few
questions through:

1. In /bin I note that there is kafka-server-stop.sh and zookeeper-server-stop.sh. I assume
the scripts should be executed in this order for a clean shutdown?
2. Clearly absent are shutdown scripts for the producer and consumer. Does this reflect the
overall design decisions about Kafka's push/pull model wherein any type of producer or consumer
shutdown will not impact the broker? If so, no need for an explicit shutdown script. Is that
correct?

----- Original Message -----
From: "Joel Koshy" <jjkoshy.w@gmail.com>
To: users@kafka.apache.org
Sent: Wednesday, December 19, 2012 2:11:22 PM
Subject: Re: Unable To Run QuickStart From CLI

You will need to use the ConsoleConsumer (see the bin directory) or create
a Java/Scala consumer connector.


On Wed, Dec 19, 2012 at 9:41 AM, Christopher Alexander <
calexander@gravycard.com> wrote:

> Hi Jun,
>
> Although this may not be the ideal method, I did get it working after I
> issued the following commands:
>
> ./sbt clean
> ./sbt clean-cache
> ./sbt update
> ./sbt package
>
> And then reran the FAQ QuickStart. Maybe newly created directories finally
> recursively inherited my permissions.
>
> I see /tmp/kafka-logs/test0/00000000000000000000.kafka but unable to open
> the file in a standard editor to view what has been logged - file is
> binary. What is the recommend application to view the topic log?
>
> ----- Original Message -----
> From: "Jun Rao" <junrao@gmail.com>
> To: users@kafka.apache.org
> Sent: Wednesday, December 19, 2012 11:53:56 AM
> Subject: Re: Unable To Run QuickStart From CLI
>
> These exceptions are at the info level and are normal. Did you see data in
> the kafka broker log?
>
> Thanks,
>
> Jun
>
> On Wed, Dec 19, 2012 at 7:59 AM, Christopher Alexander <
> calexander@gravycard.com> wrote:
>
> > Hello All,
> >
> > I am in the early stages of exploring the use of Kafka for large-scale
> > application I am authoring. Generally, the documentation has been pretty
> > good and quite pleased with getting things set-up in a couple of hours.
> > However, I am attempting to run the QuickStart using CLI to locally
> confirm
> > that producers/consumers works through Zookeeper and Kafka. I get the
> > following exception when a producer connects to Zookeeper. Subsequently,
> I
> > am unable to send/receive message. The exception is:
> >
> > [2012-12-19 10:38:15,993] INFO Got user-level KeeperException when
> > processing sessionid:0x13bb3cfbcde0000 type:create cxid:0x1
> > zxid:0xfffffffffffffffe txntype:unknown reqpath:n/a Error
> Path:/brokers/ids
> > Error:KeeperErrorCode = NoNode for /brokers/ids
> > (org.apache.zookeeper.server.PrepRequestProcessor)
> > [2012-12-19 10:38:16,032] INFO Got user-level KeeperException when
> > processing sessionid:0x13bb3cfbcde0000 type:create cxid:0x2
> > zxid:0xfffffffffffffffe txntype:unknown reqpath:n/a Error Path:/brokers
> > Error:KeeperErrorCode = NoNode for /brokers
> > (org.apache.zookeeper.server.PrepRequestProcessor)
> >
> > I would appreciate it if some could point me in the right direction.
> >
> >
> > Kind regards,
> >
> > Chris Alexander
> > Technical Architect and Engineer
> > Gravy, Inc.
> >
> > W: http://www.gravycard.com
> >
> >
>

Mime
View raw message