kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jun Rao <jun...@gmail.com>
Subject Re: setting up 0.8
Date Thu, 13 Dec 2012 15:44:23 GMT
John,

Not yet. Could you try building it on a different machine?

Thanks,

Jun

On Wed, Dec 12, 2012 at 10:59 PM, John Wang <john.wang@gmail.com> wrote:

> Hi Jun:
>
>      Is there a pre-built distribution that I can download? I am having
> trouble with maven with my  machine.
>
> -John
>
> On Thu, Dec 6, 2012 at 5:18 PM, Jun Rao <junrao@gmail.com> wrote:
>
> > Hmm, this seems like a Maven issue. Do you have a local Maven repo?
> >
> > Thanks,
> >
> > Jun
> >
> > On Thu, Dec 6, 2012 at 1:23 PM, John Wang <john.wang@gmail.com> wrote:
> >
> > > Hi guys:
> > >
> > >      Just checked out the 0.8 branch:
> > > https://svn.apache.org/repos/asf/kafka/branches/0.8
> > >
> > >      and ./sbt update does not work. (I have a machine with no previous
> > > installations of scala), I am getting:
> > >
> > > johnwang@tw-mbp13-jwang 13:20:08 !1201 ~/opensource/kafka-0.8> ./sbt
> > > update
> > >
> > > Getting Scala 2.8.0 ...
> > >
> > > :: problems summary ::
> > > :::: WARNINGS
> > > [NOT FOUND  ] org.scala-lang#scala-library;2.8.0!scala-library.jar
> (2ms)
> > >
> > > ==== Maven2 Local: tried
> > >
> > >
> > >
> >
>  file:///Users/johnwang/.m2/repository/org/scala-lang/scala-library/2.8.0/scala-library-2.8.0.jar
> > >
> > > ::::::::::::::::::::::::::::::::::::::::::::::
> > >
> > > ::              FAILED DOWNLOADS            ::
> > >
> > > :: ^ see resolution messages for details  ^ ::
> > >
> > > ::::::::::::::::::::::::::::::::::::::::::::::
> > >
> > > :: org.scala-lang#scala-library;2.8.0!scala-library.jar
> > >
> > > ::::::::::::::::::::::::::::::::::::::::::::::
> > >
> > >
> > >
> > > :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
> > > download failed: org.scala-lang#scala-library;2.8.0!scala-library.jar
> > > Error during sbt execution: Error retrieving required libraries
> > >   (see /Users/johnwang/opensource/kafka-0.8/project/boot/update.log for
> > > complete log)
> > > [error] Could not retrieve Scala 2.8.0
> > >
> > > Provide a new Scala version or press enter to exit:
> > >
> > > Ideas?
> > >
> > > Thanks
> > >
> > > -John
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message