kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neha Narkhede <neha.narkh...@gmail.com>
Subject Re: changes in zkClient library
Date Wed, 05 Dec 2012 19:33:02 GMT
That's right. Kafka 0.8 will require zkclient-0.2.

Thanks,
Neha

On Wed, Dec 5, 2012 at 11:25 AM, Jason Rosenberg <jbr@squareup.com> wrote:
> Ok,
>
> Sorry to beat a dead horse :)
>
> Are you saying that we can use zk 3.3.4 or newer, but still we need to
> include the zkclient-0.2.jar?
>
> Thanks,
>
> Jason
>
> On Wed, Dec 5, 2012 at 11:16 AM, Neha Narkhede <neha.narkhede@gmail.com>wrote:
>
>> Jason,
>>
>> I meant the former, and thanks to Otis, we now have the patched
>> version of zkclient in a public Maven repo -
>> http://search.maven.org/#artifactdetails|com.101tec|zkclient|0.2|jar
>>
>> Using zookeeper 3.3.4 and newer should work, AFAIK.
>>
>> Thanks,
>> Neha
>>
>> On Wed, Dec 5, 2012 at 11:13 AM, Jason Rosenberg <jbr@squareup.com> wrote:
>> > Neha,
>> >
>> > Are you saying that this is a custom mod to zkClient that is not in the
>> > public version, or one that exists in 3.3.5 and newer versions of the
>> > released zk client?
>> >
>> > If we use 3.3.5 or 3.3.6, should we be ok?
>> >
>> > Jason
>> >
>> > On Wed, Dec 5, 2012 at 10:41 AM, Neha Narkhede <neha.narkhede@gmail.com
>> >wrote:
>> >
>> >> Jae,
>> >>
>> >> We modified the zkclient read API to expose the zookeeper Stat object.
>> >> This is because we need to do conditional writes in some places in
>> >> Kafka. Exposing the Stat object allows us to read the previous version
>> >> of the zookeeper value, and we can use that to write the new value if
>> >> the expected version of the previous value is correct.
>> >>
>> >> Are you using zookeeper client 3.3.4 or older ?
>> >>
>> >> Thanks,
>> >> Neha
>> >>
>> >> On Wed, Dec 5, 2012 at 10:26 AM, Bae, Jae Hyeon <metacret@gmail.com>
>> >> wrote:
>> >> > Could you share what changed in zkclient-20120522.jar?
>> >> >
>> >> > I found that watchers were canceled when the zookeeper connection was
>> >> > interrupted and reconnected with another application. If the new
>> >> > zkclient-20120522 resolved this issue, I need to update this library
>> >> > in my other projects.
>> >> >
>> >> > I really appreciate
>> >> >
>> >> > Thank you
>> >> > Best, Jae
>> >>
>>

Mime
View raw message