kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Jervis <bjer...@visibletechnologies.com>
Subject Can't install 0.8
Date Mon, 03 Jun 2013 18:59:43 GMT
I tried to follow the 0.8 quickstart page to install it and got the following error on the
./sbt update stage:

[error] (core/*:update) sbt.ResolveException: unresolved dependency: org.slf4j#slf4j-api;1.7.2:
configuration not found in org.slf4j#slf4j-api;1.7.2: 'compile'. It wa
s required from com.yammer.metrics#metrics-core;2.2.0 compile
[error] Total time: 3 s, completed Jun 3, 2013 11:45:47 AM

What do I need to do to install this on Ubuntu?

Oh, and I still don't get any replies that come through this forum, so please email me directly.

I'm doing this download because we are seeing 'java heap space' errors on our Kafka brokers.
 We have 681 topics (1 partition per) with replication 2 and 2 brokers.  Each broker survives
between 4-40 hours before crashing.  I have a memory dump loaded into MAT and it shows 'DelayedFetch'
as holding 1.5GB of data (the xmx is 2GB).  I also verified that we are running with the patch
to KAFKA-671 in the 0.8 code we are running.

At the time that the crash occurred, we were not actually writing any data through Kafka and
only had one consumer on one of the 681 topics.

We only started seeing these issues when we went to our production number of topics.  We have
been running this code for about a monthwith only ~95 topics without error.

Thanks,
Bob
Mime
View raw message