kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Withers <reefed...@gmail.com>
Subject Re: package error
Date Thu, 06 Jun 2013 19:13:33 GMT
hey Balaji,

thanks of the help.  I tried:
	./sbt "++2.8.0 package"
and it still failed.  So I tried:
	./sbt "++2.9.2 package"
and it worked!

Does anyone have an idea why the 2.8.0 failed and what could I do to target scala 2.8?

thanks,
rob


On Jun 6, 2013, at 11:57 AM, "Seshadri, Balaji" <Balaji.Seshadri@dish.com> wrote:

> Try ./sbt "++2.8.0 package".
> 
> -----Original Message-----
> From: Rob Withers [mailto:reefedjib@gmail.com] 
> Sent: Thursday, June 06, 2013 11:54 AM
> To: kafka list
> Subject: package error
> 
> I am quite unfamiliar with compiling with sbt package.  What could be my issue here?
 It seems like the scala library is wrong, but where do I look for the scala jar?
> 
> thanks,
> rob
> 
> 
> "$ ./sbt package
> [info] Loading project definition from /Users/reefedjib/Desktop/rob/comp/workspace/kafka/project
> [info] Set current project to Kafka (in build file:/Users/reefedjib/Desktop/rob/comp/workspace/kafka/)
> [info] Compiling 52 Scala sources and 1 Java source to /Users/reefedjib/Desktop/rob/comp/workspace/kafka/core/target/scala-2.8.0/classes...
> [error] class file needed by TopicAndPartition is missing.
> [error] reference type Serializable of package scala refers to nonexisting symbol.
> [error] one error found
> [error] (core/compile:compile) Compilation failed
> [error] Total time: 5 s, completed Jun 6, 2013 11:47:38 AM"


Mime
View raw message