kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yavar Husain <yavarhus...@gmail.com>
Subject Re: Kafka 0.7 Quickstart Errors
Date Mon, 08 Jul 2013 09:14:12 GMT
Perfect Jun! It works. Thanks a ton.

On Mon, Jul 8, 2013 at 9:00 AM, Jun Rao <junrao@gmail.com> wrote:

> The following is the weird part. 0:0 is not a valid host and port. Could
> you take a look at the EC2 FAQ in
> https://cwiki.apache.org/confluence/display/KAFKA/FAQ? It's for the
> consumers, but may apply to the producers too.
>
> [2013-06-28 14:07:19,653] ERROR Connection attempt to 0:0 failed, next
> attempt in 1 ms (kafka.producer.SyncProducer)
> java.net.ConnectException: Connection refused
>
> Thanks,
>
> Jun
>
>
> On Sat, Jul 6, 2013 at 3:30 PM, Yavar Husain <yavarhusain@gmail.com>
> wrote:
>
> > Hi Jun
> >
> > I am still not able to run Kafka 0.7. and getting the same error as
> > described in my thread. As for Kafka Spout to work I need Kafka 0.7 so it
> > would be great if you could help me out with this. I did not understand
> > what you mentioned in your last message "wipe out both Zookeeper and
> Kafka
> > 0.8 data".I just changed the log data directories in both kafka and
> > zookeeper configs and still I am getting the same error. Isn't that
> > sufficient? What else do I need to do to wipe out the data? What
> > directories do I need to visit?
> >
> > Will the above be the reason for getting the following error:
> >
> >  [2013-06-28 14:06:05,606] INFO Creating async producer for broker id =
> > > > 0 at 0:0 (kafka.producer.ProducerPool)
> > > > 5)  Time to send some messages & oops I get this error:
> > > > [2013-06-28 14:07:19,650] INFO Disconnecting from 0:0
> > > > (kafka.producer.SyncProducer)
> > > > [2013-06-28 14:07:19,653] ERROR Connection attempt to 0:0 failed,
> next
> > > > attempt in 1 ms (kafka.producer.SyncProducer)
> > > > java.net.ConnectException: Connection refused
> > > >         at sun.nio.ch.Net.connect0(Native Method)
> > > >         at sun.nio.ch.Net.connect(Net.java:364)
> > > >         at sun.nio.ch.Net.connect(Net.java:356)
> > > >         at
> > > sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:623)
> > > >         at
> kafka.producer.SyncProducer.connect(SyncProducer.scala:173)
> > > >         at
> > > >
> kafka.producer.SyncProducer.getOrMakeConnection(SyncProducer.scala:196)
> > > >         at kafka.producer.SyncProducer.send(SyncProducer.scala:92)
> > > >         at
> > kafka.producer.SyncProducer.multiSend(SyncProducer.scala:135)
> > > >         at
> > > >
> > >
> >
> kafka.producer.async.DefaultEventHandler.send(DefaultEventHandler.scala:58)
> > > >         at
> > > >
> > >
> >
> >
> kafka.producer.async.DefaultEventHandler.handle(DefaultEventHandler.scala:44)
> > > >         at
> > > >
> > >
> >
> >
> kafka.producer.async.ProducerSendThread.tryToHandle(ProducerSendThread.scala:116)
> > > >         at
> scala.collection.immutable.Stream.foreach(Stream.scala:254)
> > > >         at
> > > >
> > >
> >
> >
> kafka.producer.async.ProducerSendThread.processEvents(ProducerSendThread.scala:70)
> > > >         at
> > > >
> > kafka.producer.async.ProducerSendThread.run(ProducerSendThread.scala:41)
> >
> > Regards,
> > Yavar
> >
> > On Thu, Jul 4, 2013 at 4:53 PM, Yavar Husain <yavarhusain@gmail.com>
> > wrote:
> >
> > > Hey Jun
> > >
> > > Thanks for your prompt response. I don't really get "wipe out both
> > > Zookeeper and Kafka 0.8 data". I just changed the log data directories
> in
> > > both kafka and zookeeper configs and still I am getting the same error.
> > > Isn't that sufficient? What else do I need to do to wipe out the data?
> > What
> > > directories do I need to visit?
> > >
> > > Thanks,
> > > Yavar
> > >
> > >
> > > On Mon, Jul 1, 2013 at 9:13 PM, Jun Rao <junrao@gmail.com> wrote:
> > >
> > >> You need to wipe out both the ZK data and the Kafka data from 0.8, in
> > >> order
> > >> to try 0.7.
> > >>
> > >> Thanks,
> > >>
> > >> Jun
> > >>
> > >>
> > >> On Sun, Jun 30, 2013 at 11:28 PM, Yavar Husain <yavarhusain@gmail.com
> > >> >wrote:
> > >>
> > >> > Kafka 0.8 works great. I am able to use CLI as well as write my own
> > >> > producers/consumers!
> > >> >
> > >> > Checking Zookeeper... and I see all the topics and partitions
> created
> > >> > successfully for 0.8.
> > >> >
> > >> > Kafka 0.7 does not work!
> > >> >
> > >> > Why Kafka 0.7? I am using Kafka Spout from Storm which is made for
> > Kafka
> > >> > 0.7.
> > >> >
> > >> > First I just want to run CLI based producer/consumer for Kafka 0.7,
> > >> which I
> > >> > am unable to. I carry out the following steps:
> > >> >
> > >> > 1)  I delete all the topics/partitions etc. in Zookeeper that were
> > >> > created from my Kafka 0.8
> > >> > 2)  I change the dataDir in zoo.cfg to point to different location.
> > >> > 3)  Now I start the kafka server 0.7. It starts successfully.
> However
> > >> > I don’t know why it again registers the broker topics I deleted?
> > >> > 4)  Now I start the Kafka Producer :
> > >> > bin/kafka-console-producer.sh --zookeeper localhost:2181 --topic
> > >> topicime
> > >> > & it starts successfully:
> > >> > [2013-06-28 14:06:05,521] INFO zookeeper state changed
> (SyncConnected)
> > >> > (org.I0Itec.zkclient.ZkClient)
> > >> > [2013-06-28 14:06:05,606] INFO Creating async producer for broker
> id =
> > >> > 0 at 0:0 (kafka.producer.ProducerPool)
> > >> > 5)  Time to send some messages & oops I get this error:
> > >> > [2013-06-28 14:07:19,650] INFO Disconnecting from 0:0
> > >> > (kafka.producer.SyncProducer)
> > >> > [2013-06-28 14:07:19,653] ERROR Connection attempt to 0:0 failed,
> next
> > >> > attempt in 1 ms (kafka.producer.SyncProducer)
> > >> > java.net.ConnectException: Connection refused
> > >> >         at sun.nio.ch.Net.connect0(Native Method)
> > >> >         at sun.nio.ch.Net.connect(Net.java:364)
> > >> >         at sun.nio.ch.Net.connect(Net.java:356)
> > >> >         at
> > >> sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:623)
> > >> >         at
> kafka.producer.SyncProducer.connect(SyncProducer.scala:173)
> > >> >         at
> > >> >
> > kafka.producer.SyncProducer.getOrMakeConnection(SyncProducer.scala:196)
> > >> >         at kafka.producer.SyncProducer.send(SyncProducer.scala:92)
> > >> >         at
> > kafka.producer.SyncProducer.multiSend(SyncProducer.scala:135)
> > >> >         at
> > >> >
> > >>
> >
> kafka.producer.async.DefaultEventHandler.send(DefaultEventHandler.scala:58)
> > >> >         at
> > >> >
> > >>
> >
> kafka.producer.async.DefaultEventHandler.handle(DefaultEventHandler.scala:44)
> > >> >         at
> > >> >
> > >>
> >
> kafka.producer.async.ProducerSendThread.tryToHandle(ProducerSendThread.scala:116)
> > >> >         at
> scala.collection.immutable.Stream.foreach(Stream.scala:254)
> > >> >         at
> > >> >
> > >>
> >
> kafka.producer.async.ProducerSendThread.processEvents(ProducerSendThread.scala:70)
> > >> >         at
> > >> >
> > kafka.producer.async.ProducerSendThread.run(ProducerSendThread.scala:41)
> > >> >
> > >> > Note that Zookeeper is already running.
> > >> >
> > >> > Any help would really be appreciated.
> > >> >
> > >> > *EDIT:*
> > >> >
> > >> > I don't even see the topic being created in zookeeper. I am running
> > the
> > >> > following command:
> > >> >
> > >> > bin/kafka-console-producer.sh --zookeeper localhost:2181 --topic
> > >> topicime
> > >> >
> > >> > After the command everything is fine & I get the following message:
> > >> >
> > >> > [2013-06-28 14:30:17,614] INFO Session establishment complete on
> > >> > server localhost/127.0.0.1:2181, sessionid = 0x13f805c6673004b,
> > >> > negotiated timeout = 6000 (org.apache.zookeeper.ClientCnxn)
> > >> > [2013-06-28 14:30:17,615] INFO zookeeper state changed
> (SyncConnected)
> > >> > (org.I0Itec.zkclient.ZkClient)
> > >> > [2013-06-28 14:30:17,700] INFO Creating async producer for broker
> id =
> > >> > 0 at 0:0 (kafka.producer.ProducerPool)
> > >> >
> > >> > However now when i type a string to send I get the above error
> > >> (Connection
> > >> > refused!)
> > >> >
> > >>
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message