kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joseph Lawson <jlaw...@roomkey.com>
Subject kafka-reassign-partitions.sh --status-check-json-file not working
Date Mon, 04 Nov 2013 17:47:27 GMT
Hi everyone,

I'm using Kafka 0.8.0 from the git repository.

I'm trying the following commands:

bin/kafka-reassign-partitions.sh --topics-to-move-json-file topics-to-move.json --zookeeper
zk-qa.us-e.roomkey.net:2181/kafka_stage/kafka_qa --broker-list "1" --execute

where topics-to-move.json is:

{"topics":
     [{"topic": "topic1"},{"topic": "topic2"}],
     "version":1
}

When I run:

bin/kafka-reassign-partitions.sh --status-check-json-file topics-to-move.json --zookeeper
zk-qa.us-e.roomkey.net:2181/kafka_stage/kafka_qa

All I see is:

Status of partition reassignment:

I expect to see some status but I cannot see anything.

When I run the reassign command again I get the following error implying that the reassignment
is taking place:

Partitions reassignment failed due to Partition reassignment currently in progress for Map().
Aborting operation
kafka.common.AdminCommandFailedException: Partition reassignment currently in progress for
Map(). Aborting operation
at kafka.admin.ReassignPartitionsCommand.reassignPartitions(ReassignPartitionsCommand.scala:195)
at kafka.admin.ReassignPartitionsCommand$.main(ReassignPartitionsCommand.scala:137)
at kafka.admin.ReassignPartitionsCommand.main(ReassignPartitionsCommand.scala)


When I look at the broker 1, I see nothing indicating that anything is happening.  I only
have a replication factor of 1 on this topic.

Is this a bug or am I doing this wrong?

Thanks!

Joe Lawson

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message