kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arjun <ar...@socialtwist.com>
Subject Re: kafka consumer not consuming messages
Date Mon, 10 Feb 2014 10:24:56 GMT
On extension to the same problem i am seeing this "INFO Closing socket 
connection to /127.0.0.1. (kafka.network.Processor)" in my log 
continuously. I searched the web and found this code in an exception 
block " 
https://apache.googlesource.com/kafka/+/40a80fa7b7ae3d49e32c40fbaad1a4e402b2ac71/core/src/main/scala/kafka/network/SocketServer.scala".

Does this have anything to do with the problem?

Why will this come up, i tried to look at the code but i am lost in it. 
Can some one please point me in a direction where i can find the answer.

Thanks
Arjun Narasimha Kota

On Monday 10 February 2014 11:57 AM, Arjun wrote:
> Hi,
>
> I started using kafka some time back. I was experimenting with 0.8. My
> problem is the kafka is unable to consume the messages. My configuration
> is kafka broker on the local host and zookeeper on the local host. I
> have only one broker and one consumer at present.
>
> What have I done:
>      1) I used the java examples in the kafka src and pushed some 600
> messages to the broker
>      2) I used the console consumer to check weather the messages are
> there in the broker or not. Console consumer printed all 600 messages
>      3) Now i used the java Consumer code, and tried to get those
> messages. This is not printing any messages. It just got stuck
>
> When was it working earlier:
>      -When i tried with three brokers and three consumers in the same
> machine, with the same configuration it worked fine.
>      -I changed the properties accordingly when i tried to make it work
> with one broker and one consumer
>
> What does log say:
>      - attaching the logs even
>
> If some one points me where I am doing wrong it would be helpful.
>
> Thanks
> Arjun Narasimha Kota
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message