kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arjun <ar...@socialtwist.com>
Subject Re: consumer not consuming messages
Date Thu, 10 Apr 2014 16:20:14 GMT
But  we have auto offset reset to smallest not largest, even then this 
issue arises? If so is there any work around?

Thanks
Arjun NArasimha Kota

On Thursday 10 April 2014 09:39 PM, Guozhang Wang wrote:
> It could be https://issues.apache.org/jira/browse/KAFKA-1006.
>
> Guozhang
>
>
> On Thu, Apr 10, 2014 at 8:50 AM, Arjun <arjun@socialtwist.com> wrote:
>
>> its auto created
>> but even after topic creation this is the scenario
>>
>> Arjun
>>
>> On Thursday 10 April 2014 08:41 PM, Guozhang Wang wrote:
>>
>>> Hi Arjun,
>>>
>>> Did you manually create the topic or use auto.topic.creation?
>>>
>>> Guozhang
>>>
>>>
>>> On Thu, Apr 10, 2014 at 7:39 AM, Arjun <arjun@socialtwist.com> wrote:
>>>
>>>   Hi,
>>>> We have 3 node kafka 0.8 setup with zookeepers ensemble. We use high
>>>> level
>>>> consumer with auto commit offset false. I am facing some peculiar problem
>>>> with kafka. When i send some 10-20 messages or so the consumer starts to
>>>> consume the messages. But if  i send only one message to kafka, then even
>>>> though consumer is active it is not trying to fetch the message. There is
>>>> nothing in logs, just the messages are being fetched by the kafka
>>>> consumer.
>>>> The messages are there in the Kafka server. Can some one let me know
>>>> where
>>>> i am doing wrong.
>>>>
>>>>
>>>> Thanks
>>>> Arjun Narasimha Kota
>>>>
>>>>
>>>
>


Mime
View raw message