kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laszlo Fogas <las...@falconsocial.com>
Subject Re: running on scala 2.11
Date Thu, 29 May 2014 11:20:32 GMT
just simply tried artifact kafka_2.10:0.8.1.1 as suggested in
https://issues.apache.org/jira/browse/KAFKA-1454 but got the error written
above


now I've cloned the repo and compiled with

./gradlew jar => success
./gradlew -PscalaVersion=2.10.0 jar => success
./gradlew -PscalaVersion=2.11.0 jar =>  FAILURE

both on trunk and 0.8.1.1 tag


the compile error is the same as here
https://github.com/davidB/scala-maven-plugin/issues/145#issuecomment-39189898

i've tried disabling zinc => got classpath errors at an other point
and upgrading zinc => had other version incompatibilities


Seems like there are issues with scala 2.11









On Wed, May 28, 2014 at 6:41 PM, Guozhang Wang <wangguoz@gmail.com> wrote:

> Hello Laszlo,
>
> Have you built Kafka with scala 2.11? You may read the README file to check
> compiling Kafka with different scala versions.
>
> Guozhang
>
>
> On Wed, May 28, 2014 at 5:45 AM, Laszlo Fogas <laszlo@falconsocial.com>
> wrote:
>
> > Hello folks,
> >
> > anybody running kafka with scala 2.11.0?
> >
> > KAFKA-1454 says it's possible.. i'm having problems though when running
> the
> > basic producer example from the wiki
> >
> > The message is *NoClassDefFoundError:
> > scala/collection/GenTraversableOnce$class*
> >
> >
> > Thanks
> >
> > Laszlo
> >
>
>
>
> --
> -- Guozhang
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message