kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <pradeep.si...@wipro.com>
Subject RE: Socket is not connected error while consuming messages using kafka
Date Mon, 04 Aug 2014 04:38:26 GMT
Even from telnet I couldn’t connect it's showing error "Connecting to 10.10.10.10 ... Couldn't
open connection to host", but I am able to connect from PuTTY.

Thanks,
Pradeep Simha
Technical Lead

-----Original Message-----
From: Jun Rao [mailto:junrao@gmail.com] 
Sent: Monday, August 04, 2014 9:57 AM
To: users@kafka.apache.org
Subject: Re: Socket is not connected error while consuming messages using kafka

This seems to be a Zookeeper connection problem. Can you telnet to the ZK server from the
consumer client host?

Thanks,

Jun


On Sat, Aug 2, 2014 at 3:20 AM, <pradeep.simha@wipro.com> wrote:

> Hi Team,
>
> I am trying to consume a message from Kafka hosted on Ubuntu server, 
> using this example:
> https://cwiki.apache.org/confluence/display/KAFKA/Consumer+Group+Examp
> le but whenever I run I get this exception:
>
> java.net.SocketException: Socket is not connected
>                 at 
> sun.nio.ch.Net.translateToSocketException(Net.java:149)
> ~[na:1.7.0_25]
>                 at sun.nio.ch.Net.translateException(Net.java:183)
> ~[na:1.7.0_25]
>                 at sun.nio.ch.Net.translateException(Net.java:189)
> ~[na:1.7.0_25]
>                 at
> sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:423)
> ~[na:1.7.0_25]
>                 at
> org.apache.zookeeper.ClientCnxn$SendThread.cleanup(ClientCnxn.java:123
> 2)
> [zookeeper-3.3.4.jar:3.3.3-1203054]
>                 at
> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1211)
> [zookeeper-3.3.4.jar:3.3.3-1203054]
> Caused by: java.nio.channels.NotYetConnectedException: null
>                 at
> sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:773)
> ~[na:1.7.0_25]
>                 at
> sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:421)
> ~[na:1.7.0_25]
>                 ... 2 common frames omitted
>
> I am trying to solve this issue from hours, I looked in config file, 
> properties file etc but still couldn't. If someone could help me in 
> this it would be highly appreciated as I am very beginner to this and 
> have no previous experience in working in this.
>
> Thanks,
> Pradeep Simha
> Technical Lead
>
> The information contained in this electronic message and any 
> attachments to this message are intended for the exclusive use of the 
> addressee(s) and may contain proprietary, confidential or privileged 
> information. If you are not the intended recipient, you should not 
> disseminate, distribute or copy this e-mail. Please notify the sender 
> immediately and destroy all copies of this message and any attachments.
>
> WARNING: Computer viruses can be transmitted via email. The recipient 
> should check this email and any attachments for the presence of viruses.
> The company accepts no liability for any damage caused by any virus 
> transmitted by this email.
>
> www.wipro.com
>

The information contained in this electronic message and any attachments to this message are
intended for the exclusive use of the addressee(s) and may contain proprietary, confidential
or privileged information. If you are not the intended recipient, you should not disseminate,
distribute or copy this e-mail. Please notify the sender immediately and destroy all copies
of this message and any attachments. 

WARNING: Computer viruses can be transmitted via email. The recipient should check this email
and any attachments for the presence of viruses. The company accepts no liability for any
damage caused by any virus transmitted by this email.

www.wipro.com
Mime
View raw message