kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gwen Shapira <gshap...@cloudera.com>
Subject Re: Issue with kafka-server-start.sh
Date Wed, 06 Aug 2014 21:26:55 GMT
These are info messages, not necessarily errors.

Do they occur in a never ending loop? Do you also see errors?
Do you ever get a successful broker registration message in the log?
(Registered broker 1 at path....)

Gwen

On Wed, Aug 6, 2014 at 1:53 PM, Shikha Srivastava
<ssrivastava@rubiconproject.com> wrote:
> Hi,
>
> I am working with kafka_2.8.0-0.8.1.1. It used to work fine but since this
> morning when I try to start the kafka-server after starting zookeeper, I am
> getting this error-
>
>  INFO I wrote this conflicted ephemeral node
> [{"version":1,"brokerid":0,"timestamp":"1407357554030"}] at /controller a
> while back in a different session, hence I will backoff for this node to be
> deleted by Zookeeper and retry (kafka.utils.ZkUtils$)
>
> [2014-08-06 13:49:22,103] INFO conflict in /controller data:
> {"version":1,"brokerid":0,"timestamp":"1407357554030"} stored data:
> {"version":1,"brokerid":0,"timestamp":"1407349766568"}
> (kafka.utils.ZkUtils$)
>
>
> I tried to stop both kafka and zookeeper and cleared all the logs and then
> tried starting it again but I am still getting this error.
>
> Can you guide me to the root cause?
>
> Thank you very much!
>
> Shikha

Mime
View raw message