kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Stein <joe.st...@stealth.ly>
Subject Re: Trying to start Kafka
Date Sun, 07 Dec 2014 23:21:15 GMT
That is for a previous version.

This is for the 0.8.2-beta quick start
https://kafka.apache.org/082/documentation.html#quickstart

/*******************************************
 Joe Stein
 Founder, Principal Consultant
 Big Data Open Source Security LLC
 http://www.stealth.ly
 Twitter: @allthingshadoop <http://www.twitter.com/allthingshadoop>
********************************************/

On Sat, Dec 6, 2014 at 3:06 PM, Mukul Jain <mukulj@gmail.com> wrote:

> I am a newebee and just downloaded 0.8.2-beta following these instructions:
>
> *> tar xzf kafka-<VERSION>.tgz**> cd kafka-<VERSION>**> ./sbt
> update**> ./sbt package*
>
> following this link : http://kafka.apache.org/07/quickstart.html
>
> when I try following :
>
>
> *> bin/zookeeper-server-start.sh config/zookeeper.properties*
>
> *Error: Could not find or load main class
> org.apache.zookeeper.server.quorum.QuorumPeerMain*
>
> Do I need to download and setup zookeeper separately.. I thought
> following lines in quick start guide mentioned that I do not need to :
>
> First start the zookeeper server. You can use the convenience script
> packaged with kafka to get a quick-and-dirty single-node zookeeper
> instance.
>
>
> Any help is appreciated.
>
>
> Thanks,
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message