kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Rosenberg <...@squareup.com>
Subject unable to delete topic with 0.8.2 rc2
Date Mon, 26 Jan 2015 03:56:03 GMT
So far, I have been unable to get delete topic to work, with release
candidate 2 for 0.8.2.

It worked ok when I ran it in the debugger locally, on a single node
instance. But when I run it in our staging environment, it is not
successfully even marking the topic for delete, for some reason.

I am setting delete.topic.enable to true (and see the confirmation of this
in the startup logs, e.g.):

INFO [main] utils.VerifiableProperties - Property delete.topic.enable
is overridden to true

I run this command:

java -cp app.jar kafka.admin.TopicCommand --zookeeper
myzkconnect:12345/mynamespace --delete --topic mytopic

log4j:WARN No appenders could be found for logger
(org.I0Itec.zkclient.ZkConnection).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN No appenders could be found for logger
(org.I0Itec.zkclient.ZkEventThread).
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.
Topic mytopic is marked for deletion.
Note: This will have no impact if delete.topic.enable is not set to true.

I then do a —list which should at least show the topic marked for deletion:

java -cp app.jar kafka.admin.TopicCommand --zookeeper
myzkconnect:12345/mynamespace --list --topic mytopic

log4j:WARN No appenders could be found for logger
(org.I0Itec.zkclient.ZkConnection).
log4j:WARN No appenders could be found for logger
(org.I0Itec.zkclient.ZkEventThread).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig
for more info.
mytopic

Note, it doesn’t list it as ‘marked for deletion’. Furthermore, waiting
multiple hours still doesn’t result in the topic being deleted.

The topic has 1 partition, 2 replicas, and no data stored.

In zookeeper, the /admin/deleted_topics/ path is empty.

The zookeeper code looks pretty straightforward, but for some reason is not
writing the deleted_topics path.  We are running zookeeper 3.4.6.

Thoughts?

Jason
​

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message