kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sa Li <sal...@gmail.com>
Subject Re: kafka monitoring
Date Thu, 08 Jan 2015 21:35:37 GMT
Thank you very much for all the reply, I am able to connect jconsole now,
by set env JMX_PORT=9999 start server. However, when I connect it I found
there is a port conflict with the kafka-run-class.sh,

Error: Exception thrown by the agent : java.rmi.server.ExportException:
Port already in use: 9999; nested exception is:
        java.net.BindException: Address already in use

I can of course to reset the JMX_PORT number other than 9999, but I am
curious, do I have to ?

thanks

AL

On Thu, Jan 8, 2015 at 11:57 AM, Gene Robichaux <Gene.Robichaux@match.com>
wrote:

> Is there a firewall between your DEV and PROD environments? If so you will
> need to open access on all ports, not just JMX port.
>
> It gets complicated with JMX.....
>
> Gene Robichaux
> Manager, Database Operations
> Match.com
> 8300 Douglas Avenue I Suite 800 I Dallas, TX  75225
>
> -----Original Message-----
> From: Sa Li [mailto:salicn@gmail.com]
> Sent: Thursday, January 08, 2015 1:09 PM
> To: users@kafka.apache.org
> Subject: kafka monitoring
>
> Hello, All
>
> I understand many of you are using jmxtrans along with graphite/ganglia to
> pull out metrics, according to https://kafka.apache.org/081/ops.html,  it
> says "The easiest way to see the available metrics to fire up jconsole and
> point it at a running kafka client or server; this will all browsing all
> metrics with JMX. .."
>
> I tried to fire up a jconsole on windows attempting to access our dev and
> production cluster which are running good, here is the main node of my dev:
> 10.100.75.128, broker port:9092, zk port:2181
>
> Jconsole shows:
>
>  New Connection
> Remote Process:
>
> Usage: <hostname>:<port> OR service:jmx:<protocol>:<sap>
> Username:            Password:
>
> Sorry about my naive, I tried connect base on above ip just can't be
> connected, do I need to do something in dev server to be able to make it
> work?
>
> thanks
>
> --
>
> Alec Li
>



-- 

Alec Li

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message