kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joel Koshy <jjkosh...@gmail.com>
Subject Re: Can't create a topic; can't delete it either
Date Tue, 03 Feb 2015 22:10:55 GMT
That would be great!

Joel

On Tue, Feb 03, 2015 at 01:39:02PM -0800, Sumit Rangwala wrote:
> Joel,
> 
> My apology for being silent on this thread. I have now been able to
> recreate the setup in a docker environment and I can now consistently
> re-create an issue with auto-topic creation. Since the exact setup is
> different I will a start another thread will the the information.
> 
> Sumit
> 
> On Thu, Jan 29, 2015 at 1:29 AM, Joel Koshy <jjkoshy.w@gmail.com> wrote:
> 
> > > If you can tell me where the find the logs I can check. I haven't
> > restarted
> > > my brokers since the issue.
> >
> > This will be specified in the log4j properties that you are using.
> >
> > On Wed, Jan 28, 2015 at 12:01:01PM -0800, Sumit Rangwala wrote:
> > > On Tue, Jan 27, 2015 at 10:54 PM, Joel Koshy <jjkoshy.w@gmail.com>
> > wrote:
> > >
> > > > Do you still have the controller and state change logs from the time
> > > > you originally tried to delete the topic?
> > > >
> > > >
> > > If you can tell me where the find the logs I can check. I haven't
> > restarted
> > > my brokers since the issue.
> > >
> > > Sumit
> > >
> > >
> > >
> > > > On Tue, Jan 27, 2015 at 03:11:48PM -0800, Sumit Rangwala wrote:
> > > > > I am using 0.8.2-beta on brokers 0.8.1.1 for client (producer and
> > > > > consumers). delete.topic.enable=true on all brokers. replication
> > factor
> > > > is
> > > > > < number of brokers. I see this issue with just one single topic,
all
> > > > other
> > > > > topics are fine (creation and deletion). Even after a day it is
> > still in
> > > > > marked for deletion stage. Let me know what other  information from
> > the
> > > > > brokers or the zookeepers can help me debug this issue.
> > > > >
> > > > > On Tue, Jan 27, 2015 at 9:47 AM, Gwen Shapira <gshapira@cloudera.com
> > >
> > > > wrote:
> > > > >
> > > > > > Also, do you have delete.topic.enable=true on all brokers?
> > > > > >
> > > > > > The automatic topic creation can fail if the default number
of
> > > > > > replicas is greater than number of available brokers. Check
the
> > > > > > default.replication.factor parameter.
> > > > > >
> > > > > > Gwen
> > > > > >
> > > > > > On Tue, Jan 27, 2015 at 12:29 AM, Joel Koshy <jjkoshy.w@gmail.com>
> > > > wrote:
> > > > > > > Which version of the broker are you using?
> > > > > > >
> > > > > > > On Mon, Jan 26, 2015 at 10:27:14PM -0800, Sumit Rangwala
wrote:
> > > > > > >> While running kafka in production I found an issue
where a topic
> > > > wasn't
> > > > > > >> getting created even with auto topic enabled. I then
went ahead
> > and
> > > > > > created
> > > > > > >> the topic manually (from the command line). I then
delete the
> > topic,
> > > > > > again
> > > > > > >> manually. Now my broker won't allow me to either create
*the*
> > topic
> > > > or
> > > > > > >> delete *the* topic. (other topic creation and deletion
is
> > working
> > > > fine).
> > > > > > >>
> > > > > > >> The topic is in "marked for deletion" stage for more
than 3
> > hours.
> > > > > > >>
> > > > > > >> $ bin/kafka-topics.sh --zookeeper
> > zookeeper1:2181/replication/kafka
> > > > > > --list
> > > > > > >> --topic GRIFFIN-TldAdFormat.csv-1422321736886
> > > > > > >> GRIFFIN-TldAdFormat.csv-1422321736886 - marked for
deletion
> > > > > > >>
> > > > > > >> If this is a known issue, is there a workaround?
> > > > > > >>
> > > > > > >> Sumit
> > > > > > >
> > > > > >
> > > >
> > > >
> >
> >


Mime
View raw message