kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaikiran Pai <jai.forums2...@gmail.com>
Subject Re: Apache Kafka 0.8.2 Consumer Example
Date Mon, 09 Feb 2015 04:53:24 GMT
Ricardo,

What does your consumer code look like? If it's too big to have that 
code inline in this mail, you can perhaps put it in a github repo or 
even a gist.

-Jaikiran

On Monday 09 February 2015 12:54 AM, Ricardo Ferreira wrote:
> Hi Gwen,
>
> Sorry, both the consumer and the broker are 0.8.2?
> A = Yes
>
> So what's on 0.8.1?
> A = It works fine using 0.8.1 for server AND client.
>
> You probably know the consumer group of your application. Can you use the
> offset checker tool on that?
> A = Yes, I know from the consumer, and the offset checker gave me nothing
> about that group.
>
> Thanks,
>
> Ricardo
>
> On Sun, Feb 8, 2015 at 1:19 PM, Gwen Shapira <gshapira@cloudera.com> wrote:
>
>> Sorry, both the consumer and the broker are 0.8.2?
>>
>> So what's on 0.8.1?
>>
>> I seriously doubt downgrading is the solution.
>>
>> You probably know the consumer group of your application. Can you use the
>> offset checker tool on that?
>>
>> Gwen
>>
>> On Sun, Feb 8, 2015 at 9:01 AM, Ricardo Ferreira <
>> jricardoferreira@gmail.com> wrote:
>>
>>> Hi Gwen,
>>>
>>> Thanks for the response.
>>>
>>> In my case, I have both consumer application and the server versions in
>>> 0.8.2, Scala 2.10.
>>>
>>> No errors are thrown, and my *zookeeper.session.timeout.ms
>>> <http://zookeeper.session.timeout.ms>* property is set to 500, although
>>> I tried 5000 and also didn't worked.
>>>
>>> I checked the offset checker tool, but it asks for a group in which I
>>> don't know which group the kafka-console-producer is using. I tried the
>>> consumer group but it gave the following message:
>>>
>>> Exiting due to: org.apache.zookeeper.KeeperException$NoNodeException:
>>> KeeperErrorCode = NoNode for /consumers/test-consumer-group/offsets/test/0.
>>>
>>> Perhaps the solution is downgrade the consumer libs to 0.8.1?
>>>
>>> Thanks,
>>>
>>> Ricardo
>>>
>>> On Sun, Feb 8, 2015 at 11:27 AM, Gwen Shapira <gshapira@cloudera.com>
>>> wrote:
>>>
>>>> I have a 0.8.1 high level consumer working fine with 0.8.2 server. Few
>>>> of them actually :)
>>>> AFAIK the API did not change.
>>>>
>>>> Do you see any error messages? Do you have timeout configured on the
>>>> consumer? What does the offset checker tool say?
>>>>
>>>> On Fri, Feb 6, 2015 at 4:49 PM, Ricardo Ferreira <
>>>> jricardoferreira@gmail.com> wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> I had a client running on Kafka 0.8.1 using the High-Level consumer API
>>>>> working fine.
>>>>>
>>>>> Today I updated my Kafka installation for the 0.8.2 version (tried all
>>>>> versions of Scala) but the consumer doesn't get any messages. I tested
>>>>> using the kafka-console-consumer.sh utility tool and works fine, only
my
>>>>> Java program that not.
>>>>>
>>>>> Did I miss something? I heard that the API changed, so I'd like to know
>>>>> if
>>>>> someone can share a simple client with me.
>>>>>
>>>>> Please, respond directly to me or just reply all because I am not
>>>>> currently
>>>>> subscribed to the group.
>>>>>
>>>>> Thanks,
>>>>>
>>>>> Ricardo Ferreira
>>>>>
>>>>


Mime
View raw message