kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gwen Shapira <gshap...@cloudera.com>
Subject Re: Apache Kafka 0.8.2 Consumer Example
Date Sun, 08 Feb 2015 18:19:52 GMT
Sorry, both the consumer and the broker are 0.8.2?

So what's on 0.8.1?

I seriously doubt downgrading is the solution.

You probably know the consumer group of your application. Can you use the
offset checker tool on that?

Gwen

On Sun, Feb 8, 2015 at 9:01 AM, Ricardo Ferreira <jricardoferreira@gmail.com
> wrote:

> Hi Gwen,
>
> Thanks for the response.
>
> In my case, I have both consumer application and the server versions in
> 0.8.2, Scala 2.10.
>
> No errors are thrown, and my *zookeeper.session.timeout.ms
> <http://zookeeper.session.timeout.ms>* property is set to 500, although I
> tried 5000 and also didn't worked.
>
> I checked the offset checker tool, but it asks for a group in which I
> don't know which group the kafka-console-producer is using. I tried the
> consumer group but it gave the following message:
>
> Exiting due to: org.apache.zookeeper.KeeperException$NoNodeException:
> KeeperErrorCode = NoNode for /consumers/test-consumer-group/offsets/test/0.
>
> Perhaps the solution is downgrade the consumer libs to 0.8.1?
>
> Thanks,
>
> Ricardo
>
> On Sun, Feb 8, 2015 at 11:27 AM, Gwen Shapira <gshapira@cloudera.com>
> wrote:
>
>> I have a 0.8.1 high level consumer working fine with 0.8.2 server. Few of
>> them actually :)
>> AFAIK the API did not change.
>>
>> Do you see any error messages? Do you have timeout configured on the
>> consumer? What does the offset checker tool say?
>>
>> On Fri, Feb 6, 2015 at 4:49 PM, Ricardo Ferreira <
>> jricardoferreira@gmail.com> wrote:
>>
>>> Hi,
>>>
>>> I had a client running on Kafka 0.8.1 using the High-Level consumer API
>>> working fine.
>>>
>>> Today I updated my Kafka installation for the 0.8.2 version (tried all
>>> versions of Scala) but the consumer doesn't get any messages. I tested
>>> using the kafka-console-consumer.sh utility tool and works fine, only my
>>> Java program that not.
>>>
>>> Did I miss something? I heard that the API changed, so I'd like to know
>>> if
>>> someone can share a simple client with me.
>>>
>>> Please, respond directly to me or just reply all because I am not
>>> currently
>>> subscribed to the group.
>>>
>>> Thanks,
>>>
>>> Ricardo Ferreira
>>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message